Thunderbird: Not able to send mail when traveling [Archive] - Glock Talk

PDA

View Full Version : Thunderbird: Not able to send mail when traveling


ESPIONAGE
03-31-2009, 10:00
need some help here with thunderbird. works well when home, but when i travel (wherever it may be) i can only receive and not send.

is there an easy solution to this? it's all updated to the latest, yada yada.

Tennessee Slim
03-31-2009, 10:24
Do I understand that you are able both to send and receive from this laptop when you are home but can only receive when you're away from home?

In the T-Bird app, go to Tools> Account Settings>
In the left pane, highlight the line at the bottom that reads "Outgoing Server (SMTP)"
Post the configuration information from the right hand pane, lower window (censor your User Name).

bradleybear
03-31-2009, 10:27
Many ISP restrict the use of their SMTP server unless you have an IP that is theirs.
Therefore when you are not at home you will be using a different IP that probably does not belong to them and the mail server will block you from sending. You can receive in this situation though.

Best solution is have a gmail, hotmail, yahoo mail etc account and use that for sending while on the road. You can still recieve from your normal email while sending from your external mail.

If you want to be sure you can always test another mail client to see if it acts the same way. But my first guess is above

ESPIONAGE
03-31-2009, 11:03
i believe you are correct on the smtp only allowed from isp, and i understand about sending from another account, but it has to come from my website account, which I have setup in thunderbird.

also, how do people with outlook who travel, send email.

there has to be a way to do it, or configure some generic smtp server or something to use whatever isp that offers service wherever i am at, no?

Tennessee Slim
03-31-2009, 11:16
Sending with Outlook on the road usually is done either thru VPN to the Exchange Server or Outlook Web Access (OWA).

AFAIK, you can set up multiple POP accounts on T-Bird (I have about 10) but it only offers settings for a single SMTP server.

ESPIONAGE
03-31-2009, 11:44
is that how outlook works, ok.

as far as multiple accounts, ur right, yes. you can add other smtp's i think, but then you have to switch which you want. either way it's easy to edit.

i can't be the only one that travels, and uses thunderbird, and sends mail. i would think there is a way to work this.

Tennessee Slim
03-31-2009, 11:57
I have T-Bird on both my laptop and on a thumb drive (Portable T-Bird) The SMTP settings in both are configured identically to my desktop PC and all three work every time, regardless of what continent I'm on.

ESPIONAGE
03-31-2009, 12:04
can you actually SEND email from abroad or even other states? cuz it hasn't worked for me when in NY either. same behaviour. i tried portable as well.

what are your smtp settings in thunderbird?



separate question, when I am home, if using thunderbird, i have several accounts, but i can only send from 1 of my isp's account. i cannot not send from hotmail, gmail, yahoo, or even my other accounts with isp's domain. just the primary isp account. weird.

BigSexy
03-31-2009, 12:09
but it has to come from my website account

Do you have your website setup on a home server or with a web hosting provider? Does your web host provide email relay? You might be able to bounce through their out going server.

ESPIONAGE
03-31-2009, 12:24
i have a web hosting provider using cpanel. linus based. if there is a way to do it from their server then great. otherwise, it seems like wherever i go, i have to find out the isp at that location, then change the smtp.

it just seems weird, that i imagine there are lots of people using thunderbird, that perhaps go to internet cafes and send out email. wondering why it's not so simple.

as well, if you know anything about my other question (maybe i should start a new thread?) about not being able to send out email from other accounts, and only the primary account.

Tennessee Slim
03-31-2009, 13:58
can you actually SEND email from abroad or even other states?...
As I noted earlier, yes, I can send using any of my three mobile T-Birds (I forgot I also have it on a Linux laptop) from anywhere on earth. I have used it successfully in Canada, Central and South America, Europe and Southwest Asia.

...what are your smtp settings in thunderbird?...
Description: Earthlink
Server name: smtpauth.earthlink.net
Port: 25
"Use name and password" is checked
"User Name:" is entered as per my Earthlink account
Under "Use secure connection:" I have selected the radio button for "TLS, if available"

...Separate question, when I am home, if using thunderbird, i have several accounts, but i can only send from 1 of my isp's account. i cannot not send from hotmail, gmail, yahoo, or even my other accounts with isp's domain. just the primary isp account. weird.
T-Bird can only be configured for one SMTP server at a time. However, if a particular installation is configured with more than one POP accounts, when you select "Write" and the draft E-mail template opens, the "From" line will have a pull-down curtain. That pull-down will list all the POP accounts you have configured. The E-mail address of the account you select from that list is the one that will show up in the "From" window when it reaches your recipient. It still sends through the single SMTP server you have configured, and anyone with basic computer skills can look at a given E-mail's "Message Source" and determine the actual sending address, but to cursory examination, it will look like it was sent from the address you selected from that pull-down.

Many free E-mail accounts are strictly web-only and will not allow you to send using any E-mail client. They pay for their site by posting advertisements on the web page, which you are obliged to use. If you use a local E-mail client (such as T-Bird), they lose the ability to force you to view their adverts. Some free E-mail services permit you to receive and/or to send with a local client, some do not.

EDIT:
If you select to send "From" one of the listed alternate E-mail addresses (which remember, is just camouflage), and the recipient selects "Reply", the return E-mail address will be for the "fake" account you selected from the pull-down list, not for the account linked to the SMTP server.

ESPIONAGE
03-31-2009, 23:24
regarding the second part my question with multiple accounts. the problem is that lets say i have my comcast email set up in t-bird, well i actually have the primary email account, and then a few subaccounts. i also have others like hotmail, yahoo, etc.

the thing is, from home, when i compose an email, i CAN select from the drop down menu whichever email address i want in the FROM part, but the only one that works is ONLY 1 of the comcast accounts. you would think that any of them would work. it only started doing this the last few months. i am using the latest thunderbird. maybe earlier builds did not cause this problem???

noway
04-01-2009, 05:30
OP, are you by any chance on AOL?

JimmyN
04-01-2009, 05:59
You can set up as many smtp servers as you want in Thunderbird.

Tools>Account Settings
Highlight 'Outgoing Server' in the left pane, click the "Advanced" button
Click "Add" to add a new smtp server.

You can then assign servers to specific accounts, and set a default server.
I have two personal email accounts, and one company account. Those three accounts can send mail from one of three mail servers.

The two personal accounts normally use Cox's smtp server to send out (default).
The business account relays through Cox using port 587, and sends out of our company mail server. Or when I compose I can use the 'From' dropdown to choose the smtp server I want the mail to originate from.

Cox blocks port 25 to prevent relaying. So the smtp server settings for the business account uses port 587 to get through Cox's system. Our company mail server accepts requests from either port 25 or port 587.

So I can sit at my home office, using Cox as my IP provider, and still send mail out of our company server, without faking the 'From' information.

noway
04-01-2009, 06:46
Another option could be the use of SSH port forwarding. I use this on a regular basis to send mail thru one of my 2 mail-servers setting abroad. I just redirect local 127.0.0.1 25/tcp to the remote mailserver port 25, since almost all mailservers allows sending of mail via 127.0.0.1 loopback address.

i.e

elsol: root# ssh -L 25:198.207.xxx.6:25 root@198.207.xxx.6




So now I have to not worry about anybody preventing me from relaying and my connection is secured thru encryption.

Tennessee Slim
04-01-2009, 08:50
You can set up as many smtp servers as you want in Thunderbird.

Tools>Account Settings
Highlight 'Outgoing Server' in the left pane, click the "Advanced" button
Click "Add" to add a new smtp server....
Wallaby darned. Funny thing is, my T-Bird doesn't show an "Advanced" button. But there is a note, "Although you can specify more than one outgoing server (SMTP), this is only recommended for advanced users...."

Wonder why I don't have an "Advanced" button? I'm on v2.0.0.21. How bout you, Jimmy.

JimmyN
04-01-2009, 11:35
You're right that was a little misleading. That is from the older version, sorry about that, I should have been paying attention.

I was looking at Thunderbird on my UNIX system, which still uses V1.5, as I am too lazy to compile the latest version. Version 1.5 and earlier do have an "Advanced" button.

But on my Windows system using version 2.0.0.9 they have eliminated one screen. Highlighting 'Outgoing Server' in the left pane now brings up the add server dialog box.

Just click on the 'Add' button to add a server.
After you are done BE SURE you have selected one of the servers as the default, that will keep you out of trouble. (Use your original server)
Close Thunderbird and restart it

To select the server to use for a specific account:
Tools>Account Settings
Highlight the account name in the left pane.
In the right pane, on the bottom, you will have a dropdown menu to select the Outgoing server (SMTP) for that account. It will then use that server rather than the default for all mail sent from that account.

But if you use Global Inbox it may be a little different. I don't use global, as I prefer to keep the mail in each account, since some is private and some is business. That way all my sent and received is together for each account.

So I have three accounts in the left pane, plus 'Local Folders' which I don't use, and the Outgoing Server listing.

Tennessee Slim
04-01-2009, 11:44
That note I posted would seem to indicate v2.0.0.21 can accommodate multiple SMTP servers but I can't figure out how to configure 'em.

ESPIONAGE
04-01-2009, 12:37
OP, are you by any chance on AOL?
noway, no i dont have aol service, i have comcast. unles you mean im services, then i do have accounts in msn messenger, aol, and yahoo messenger

manish07
04-04-2009, 22:22
I think its caused from your bad server while traveling.

Blitzer
04-04-2009, 23:12
Many ISP restrict the use of their SMTP server unless you have an IP that is theirs.
Therefore when you are not at home you will be using a different IP that probably does not belong to them and the mail server will block you from sending. You can receive in this situation though.

Best solution is have a gmail, hotmail, yahoo mail etc account and use that for sending while on the road. You can still recieve from your normal email while sending from your external mail.

If you want to be sure you can always test another mail client to see if it acts the same way. But my first guess is above


Ditto++++++++++++++++++++++++=== :supergrin:

JimmyN
04-05-2009, 07:29
That note I posted would seem to indicate v2.0.0.21 can accommodate multiple SMTP servers but I can't figure out how to configure 'em.

I put setup instructions in my post #17. You should be able to do it with that information, if not let me know and I'll help you out.

-------------------

separate question, when I am home, if using thunderbird, i have several accounts, but i can only send from 1 of my isp's account. i cannot not send from hotmail, gmail, yahoo, or even my other accounts with isp's domain. just the primary isp account. weird.

Your ISP is blocking port 25 when their server is not the destination, so mail sent to hotmail, gmail, etc. is just being dumped into the bit bucket and never goes anywhere.

At home, or your business location, emails are sent out from your ISP's mail server. So your email client sends the SMTP request on port 25, which your IP detects as email and routes it to their mail server.

When connected through a different ISP they may block port 25 to prevent mail relaying through their server. Any port 25 requests that are just passing through and not destined for their server get dumped in the black hole. So when you do a normal mail send it doesn't get anywhere. In this case your home ISP is blocking mail from relaying through to hotmail, gmail, etc, to prevent spamming.

Your home ISP may allow mail to be received on port 587, so you can get past the port 25 blocking, and send out of your server while on the road or in another location. But I doubt hotmail, gmail, etc allow requests to 587 because of the spam mail problem

I know Cox blocks port 25, and doesn't provide port 587 as a secondary port, I've talked to them several times about this and it doesn't appear they will ever change their policy. But my other ISP will receive mail on either port 25 or port 587, so my email client is set to always use 587 when sending from that account.

And our company mail server is sitting right here next to me, so of course I have it configured to use 25 and 587, so employees on the road can send out of the company server.

Call your home ISP and see if their mail server accepts requests from port 587, so you can get past the port blocking and send from your home account when on the road. Probably not much you can do about the hotmail, gmail problems except use web based email when sending.

Kevin108
04-05-2009, 12:12
Most of the time you need to change your SMTP port to 587. YMMV