new glock 19 extraction problems [Archive] - Glock Talk

PDA

View Full Version : new glock 19 extraction problems


ca0617
12-11-2009, 08:13
Hey, I just recently bought a new glock 19 serial nsw... Well long story short in the first 45 rounds i had a light primer strike and three stove pipes. Since ive never have had a problom with the other ten glocks that i own i was chalking it up as a mag/ammo problom. I do own another glock 19 and shot some ammo from work out of it but the mags have been loaded for four months. Any other ideas? I dont really want to send it off unless i have to. Im not a real big fan of glocks customer service.

Marky Mark
01-11-2010, 18:46
I have a brand new G19 that stovepipes every 10 rounds. It also prints 3 inches high and left at 10 yards. I shot it side by side with an identical G19, using the same magazines and ammunition. In 23 years of shooting thouands of rounds thru 6 different Glocks, I've never had one not shoot point of aim or stovepipe.

I called Glock and the told me to send it in, which I will, but I'm a liittle bothered by this. My primary G19 has been flawless, as have the others I'v owned.

HAMMERHEAD
01-11-2010, 19:12
I'll bet the extraction issues are from a new, stiff pistol firing wimpy factory ammo. Try a box of Speer Lawman FMJ or some quality SD ammo to get the slide moving a little faster.
Speer Lawman consistently clocks faster than typical practice ammo, and should cycle better.

xp100
01-12-2010, 05:37
I agree with Hammerhead. I loaded up some 115 gr for some reduced load shooting and they would not push the slide all the way back causing FTE.

xp100
01-12-2010, 05:39
Has anyone tried reduced loads with a weaker spring?

DJ Niner
01-13-2010, 01:59
Hey, I just recently bought a new glock 19 serial nsw... Well long story short in the first 45 rounds i had a light primer strike and three stove pipes. Since ive never have had a problom with the other ten glocks that i own i was chalking it up as a mag/ammo problom. I do own another glock 19 and shot some ammo from work out of it but the mags have been loaded for four months. Any other ideas? I dont really want to send it off unless i have to. Im not a real big fan of glocks customer service.

I have a brand new G19 that stovepipes every 10 rounds. It also prints 3 inches high and left at 10 yards. I shot it side by side with an identical G19, using the same magazines and ammunition. In 23 years of shooting thouands of rounds thru 6 different Glocks, I've never had one not shoot point of aim or stovepipe.

I called Glock and the told me to send it in, which I will, but I'm a liittle bothered by this. My primary G19 has been flawless, as have the others I'v owned.I'm curious whether you folks cleaned and lubricated your Glocks prior to firing them for the first time, as stated in the manual. I've now heard more than a few folks with new guns and this type of problem, and for most of those that didn't, a cleaning/lubing solved the problems.

I think that stuff that Glock puts on the guns to keep them rust-free while in transit/storage LOOKS and feels like lube, but performs like anti-lube if you try to shoot it without cleaning it off. Clean and lube in accordance with the manual, splurge on some decent ammo, and let us know what happens. After the gun is broken-in, it'll probably shoot anything, but when new, I agree with HAMMERHEAD's opinion on ammo -- full-power is better.

Obviously, this won't fix a point-of-impact problem, but cheap ammo may have something to do with that, too (if that's what you're using).



.

HAMMERHEAD
01-13-2010, 21:35
Has anyone tried reduced loads with a weaker spring?
My first Glock, a G-34, wouldn't cycle light practice ammo reliably. I bought a tungsten guide rod and a 15 pound recoil spring, worked like a charm with 115 grain practice ammo. After the pistol had a couple thousand rounds through it, it would cycle anything with the stock spring. I also developed a tighter grip which helps too.