New(to me) USP.45 prob? [Archive] - Glock Talk

PDA

View Full Version : New(to me) USP.45 prob?


twoscoops
03-19-2010, 04:18
I just picked up a traded in USP .45 and shot it for the first time yesterday and noticed that the slide doesnt lock back on an empty mag. I was wondering if this is common, mag, or something else. Gun shot great and I liked it alot. Thanks for any info.
Chris

H&K 4 LIFE
03-19-2010, 08:04
How many mags. do you have for the pistol? Does it do it only on one mag. or all of them?

This used USP likely has worn magazine springs. Replacing the springs with Wolff +10% springs is usually a quick way to fix the problem entirely.

http://www.gunsprings.com/Semi-Auto%20Pistols/HECKLER%20%26%20KOCH/USP/cID1/mID26/dID136

twoscoops
03-19-2010, 09:45
Came with 3 and does it on all, 99% of the time. Ill check into the mag springs as that was something I was going to do anyway.
Thanks,
Chris
ps. thanks for the link

joe_jitsu
03-20-2010, 14:20
As stated above, mag springs are one likely culprit. Also check the follower and slide stop tab for excessive wear. Of course, it is possible to "ride" the slide stop lever accidentally while shooting.

Do they lock back by hand on an empty mag?

HK Dan
03-20-2010, 16:28
Also? Your thumb might be riding the slide lock lever (holding it down).

Get some Wolf springs anyway, they're cheap insurance.

twoscoops
03-20-2010, 18:12
Thanks for the replys and no, they dont lock by hand on an empty mag either.

twoscoops
03-21-2010, 14:37
It was the mag springs. Stretched them out by hand and works fine. New springs on the way!!!