Problem With Slide Locking Open When Firing [Archive] - Glock Talk

PDA

View Full Version : Problem With Slide Locking Open When Firing


jblack58
03-30-2010, 19:50
I took my brand new glock 23 to the range for the first time and had a problem with the side locking open several times while firing with rounds still left in the mag. Sometimes it would happen as much as three times in a row. It was not due to a jammed round as I was able to release the slide by pushing down on the slide release which then chambered the next round in the mag. I took it home, cleaned and lubricated it, then took it back and had the same problem. Before I fired it for the first time I had replaced the slide lock and mag release with extended ones as I have done on my other glocks. Does anyone have any suggestions as to what might be the problem?

mercury0_0
03-30-2010, 20:26
Most of the time when this happens it's because during recoil your thumb is pushing the slide stop lever up and causing it to lock open. Next time you hit the range, try moving your thumb completely out of the way. Actually angling it up and to the left (if you're right handed) away from the frame of the pistol.

MrVvrroomm
03-30-2010, 21:04
Before I fired it for the first time I had replaced the slide lock
Your slide lock spring is not under the pin.

Field strip your pistol. When you flick the slide lock does it snap back to home position?

Glockrunner
03-30-2010, 21:12
Your slide lock spring is not under the pin.

Field strip your pistol. When you flick the slide lock does it snap back to home position?

If you're NOT hitting it with your thumb, this is the cause.

jblack58
03-31-2010, 08:13
Thanks everyone for your help. My spring is under the pin and the lock does spring back when I flick it. So it must be that I've unknowingly changed my grip due to not firing during the winter months. Boy do I feel dumb! Thanks again everyone.

Brad_G
03-31-2010, 09:34
Hey, don't feel bad. I went from shooting 1911s to Glocks. My automatic reaction was to rest my right thumb on something. I couldn't figure out why my loads were not locking the slide to the rear when the mag went dry!