Glock 22 chainfire? (long post) [Archive] - Glock Talk

PDA

View Full Version : Glock 22 chainfire? (long post)


lloydchristmas
06-04-2010, 18:47
Hello. New to Glocktalk and this will be my first post. I was trying to post this question quite a while ago, but it took a long time to become an approved member. In the meanwhile, I tried to read as much as I could, but did not see a thread topic consistent with my problem.

First, some background. I work as a Police Officer for a fairly small city. We only have 14 sworn Officers. We are allowed to choose between the Glock models 22 and 23 for our duty weapon. I carry a 22, serial number KLB941. Compared to some area departments, we train with our firearms quite a bit, but certainly nothing excessive. I approximate having only 4-5000 rounds through the gun.

At our last training session, I was on the firing line completing some look-shoot exercises. It went something like this;

pull trigger=bang
pull trigger=bang
pull trigger=bang
pull trigger=bangbangbangbang!

The range master called a cease-fire, and I stepped off the line to check my weapon. I field stripped it, brushed it out, but didn't notice anything obviously amiss. After reassembly, I stepped back to the line, inserted a fresh magazine, and, long story short, basically achieved the same results. The weapon would go full-auto on its own volition, but would not empty the magazine when it did so.

I am not a Glock armorer, but I am a certified armorer for the Colt M-16, AR-15 variants, and 9mm subgun families. My basic premise then was that there was a problem between the sear and the firing pin. We do have an Officer that is a certified Glock armorer, but after inspection, he was not comfortable diagnosing the problem, as 1) He took the course quite a while ago, and 2) We really haven't had any problems with the weapons yet that he needed to address.

While waiting to be verified on this site, so I could ask you your opinion, I contacted Glock directly in GA and related my problem to them. They immediately sent (free of charge) a new trigger assembly with springs, and a new striker/firing pin assembly and spring. The department armorer installed them, and my pistol has worked flawlessly thus far. There was no packing slip with the parts, so I could not even tell you what the part numbers were that they sent.

My questions I guess are these;
If I explained the scenario properly, was I correct in assuming the sear and firing pin were the most likely culprits, and since these are the parts Glock sent, I am also assuming this should fix the issue?

Since the rest of the department also carries Glocks, is this something we need to be concerned about with the other Officer's weapons?

I would really like to be more confident in the weapon, as I carry it every day, and would really like it to work properly in the event I would need it. Maybe what I'm looking for is a little reassurance?

Thanks in advance

JR
06-04-2010, 20:14
Yes you are correct.... that was a long story.
FYI: There is no "sear" in the Glock pistol. There is a connector.
I suspect the issue was with the trigger bar engagement (confirm using an orange SCP) and you were experiencing a slam fire. This situation sometimes happens with our connectors. No big deal... change the trigger parts and your good to go.
You will know immediately if there is an issue with your parts. It will run correctly or it will not. No worries about the other guns. You would already know if there was a problem. You are good to go.