Help with trigger [Archive] - Glock Talk

PDA

View Full Version : Help with trigger


.45 guy
06-13-2010, 16:11
Could someone give a hand here? I just put a new Wilson trigger in my Springfeild, Put it back together and hammer wont drop. I fiqure the sear and disconnector are wrong The photos I've found on line arnt very good.

Tubemkr
06-13-2010, 16:42
A couple things come to mind...
First be certain your flat spring is correctly installed with the tip of the left leaf behind the surface it acts against. They easily can be stuck in front of or underneath the proper location. Secondly, be sure that the pretravel tabs on the trigger aren't bent too far to prevent resetting the sear disconnector assembly. Also be certain the overtravel screw isn't adjusted too far in.

Quack
06-13-2010, 17:45
^ good advice :)

Don Glock
06-13-2010, 17:47
make sure the flat area of the disconnector is against the trigger bow, and also check the trigger overtravel screw.


1911forum is a much better platform for these issues. PM is you need any help, my friend :)

.45 guy
06-13-2010, 21:46
Thanks for the assist guys. I did post on 1911. I don't get on there much for personal reasons. Everything works, kinda.. Some times the gripsafety wont reset. If i physically pull the trigger foward with my fingers the safety will reset.

Quack
06-13-2010, 21:49
take it apart and make sure everything is installed correctly.

since the GS won't reset, it might be the Sear spring.

Tubemkr
06-13-2010, 22:51
take it apart and make sure everything is installed correctly.

since the GS won't reset, it might be the Sear spring.

I agree that the sear spring is most likely at fault here.

.45 guy
06-14-2010, 21:51
I put the original trigger back in. Works perfectly. I'm with you, I'm going to replace the sear spring and sear.