Netbook, Num-lock, Windows 7 [Archive] - Glock Talk

PDA

View Full Version : Netbook, Num-lock, Windows 7


Kith
06-16-2010, 18:40
Heres one for you:

Friends kid has a netbook. Forget what brand. Running Windows 7 with a Targus usb num-pad. No software for the num-pad.

No num-lock key on the keyboard, though a num-pad can be accessed through the function key. (The numbers are blue on the keys)

I bought him a usb num-pad, and we have a problem with it.

When we press a key on the num-pad, an 'icon' pops up on the screen with the words "off" and "on". The word "on" is highlighted, and then it goes away.

Same exact thing happens every time we press a key on the num-pad.

The icon represents the num-lock function, but not sure how to describe what it looks like.

The num-pad won't work because of this. It turns the num-lock to "on" when a key is pressed, but that is all. The "on" state is not saved by windows between button presses.

Question:
Is there a setting in windows 7 to automatically turn the num-lock function on for the computer?


Things I have tried:
-Keyboard settings in control panel. No help here.

-Searched through windows 7 for a num-lock "on" or "off" setting, but couldn't find one.

-Device manager settings for the usb device. No help here.

-Edited the registry key under Hkey local users "keyboard" to turn on the num-pad, didn't help.

Further changed the registry key to have all(num,scroll, etc..) locks on by default, with still no success.

-Changed Num-lock to "on" by default on the BIOS for the motherboard on the netbook. Didn't work either, once windows took over it reset the num-pad to "off" by default.

Any suggestions?

(I knew the keyboard registry key probably wouldn't work since it was a seperate HID, but figured it was worth a shot.)

jpa
06-18-2010, 20:49
any luck on the 10-key manufacturer's web site?

http://targus.custhelp.com/cgi-bin/targus.cfg/php/enduser/std_adp.php?p_faqid=716&p_created=1145297648&p_sid=zNZlNN2k&p_accessibility=0&p_redirect=&p_srch=1&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MzcsMzcmcF9wcm9kcz05LDI1JnBfY2F0cz0mcF9 wdj0yLjI1JnBfY3Y9JnBfcGFnZT0x&p_li=&p_topview=1

Kith
06-20-2010, 08:47
Yes, tried there - met with no success.

Thank you for the suggestion though, I do appreciate it.

The kid called me a little while ago, said he solved the problem but has no idea how he did it. He's bright for a 10 year old, but we are still working on his 'scientific method'

I'm looking forward to finding out what he did.

Bado
06-20-2010, 09:26
try a standard usb keyboard. Hit the numlock and make sure it is working. Windows retains this setting. Then switch the keyboard with the keypad.

Kith
06-20-2010, 09:35
Bado - good suggestion!

Windows saves the setting in the registry, under the registry key entries I mentioned above - I had bypassed the hardware swap and did it manually through the registry.

Appreciate the advice!