Stumped.....again! [Archive] - Glock Talk

PDA

View Full Version : Stumped.....again!


Generalcarry
07-28-2010, 05:19
Stuck again. Iíve been trying for about 5 days to connect 2 computers to a printer. The deal is:
1. Printer hooked up to my desktop.

2. My desktop (running XP) hardwired to printer/router. These work fine.

3. Desktop (running Ubuntu) hardwired to router.

4. Notebook (running Windows 7) connected to router wirelessly.

On my XP Iíve selected share the printer, made it the default printer, gave it a location and named it.
I copied the same information on the other 2 computers.

I then downloaded and installed updated drivers for the printer on all 3 computers.
My XP works fine, but the other 2 computers recognize the printer, Iím able to select preferences in the printer and Iím able to do everything but print. All the print jobs seem get stuck in quiqe (?sp) . Iím pretty, kinda sure I restarted everything, but not at the same time (?).

Any ideas???
Thanks once again.

Lake Effect
07-28-2010, 06:41
Are the 2 printers paused? Click the little printer icon in the tray, when the box pops up select printer. If there is a check mark next to PAUSE click on PAUSE( to un-pause) and should start printing. Only thing i can think of since you can see the printer.

JimmyN
07-28-2010, 06:45
I've had a similar problem before, so try this.

First I'd make sure all three computers belong to the same workgroup.

When you add the printer on another PC select 'Local Printer' rather than 'Network printer'. It's not truly a network printer, but a shared local printer. Make sure there is no check in "Automatically detect and install my PnP printer".

In the "Add Printer Wizard" dialog box you'll even see a note explaining that. "To set up a network printer that is not attached to a print server use the "Local printer" option".

Click "Next". Select "Create a new port" on the next screen, and choose "Local Port" from the dropdown list.
Click "Next" and enter a port name in the format "\\host name\printer name"
The host name is the name of the PC with the printer connected to it, and the printer name is the share name you gave it when you selected "Share this printer".

IIRC at that point you'll be shown a list of printer manufacturers and models to choose from. If your exact printer model is not shown you will also likely have a "Have Disk" option. Or you can pick a similar printer, then after it's installed go into printer properties and install the correct/updated driver there.

Then print a test page and it should work. If not I was never here, and don't know anything about it.

Pierre!
07-28-2010, 07:19
What Jimmy said, AND - Make sure that bi-directional printing is unchecked. This is especially important if one system is 64bit and the other is 32bit.

That one twisted me up for a bit too... :supergrin:

Let us know you got it, K?

Generalcarry
07-28-2010, 11:04
Well I've changed some applicable settings given here (ei workgroup, bi-directional...) but still can't print.
Doing one computer at a time, Using Ubuntu, in order to fix my printing error I have to "go into printer:
right click the printer icon and select "Enabled" which will NOT stay checked.
I also right clicked "properties" selected Policies, and tried to select "Enabled" there. I was able to check the Enabled box but if I hit Apply, after a second, the Enabled box unchecks itself. The same thing happens when I try to hit OK.
Bottom line, I can't keep that darn Enabled" box checked.
Any ideas on the Linux computer?

Linux3
07-28-2010, 12:35
Can you make the Ubuntu system the print server?
In my experience that's easier to get working.

https://help.ubuntu.com/community/NetworkPrintingFromWinXP

Drjones
07-28-2010, 12:39
Make sure your desktop running XP is TOTALLY up to date through Windows Update.

I was having a HELL of a time getting a computer running Vista to "see" the printer connected to the XP machine and found out it was because some update had not been applied to the XP machine.

XP machine was also running SP2, NOT 3, so make sure you have XP SP3.

U-phorik407
07-30-2010, 08:42
just a real silly question to the OP. Forgive me, it's been a little time since I've seriously dabbled with my Linux boxes but you are logged in as root or a super user, or u have the correct rights to change things in the print settings right?

Generalcarry
07-30-2010, 09:17
just a real silly question to the OP. Forgive me, it's been a little time since I've seriously dabbled with my Linux boxes but you are logged in as root or a super user, or u have the correct rights to change things in the print settings right?


I'm a Linux neophyte and the only one using the computer so I must be, unless, you have to specify the fact you are the root/super user.
i

Green_Manelishi
07-30-2010, 09:54
It can be done. In my wee hoos we had 5 (now 4) 'puters printing to an old HPV40xi. One 'puter ran Ubuntu, one XP, two Vista, one OS X. The printer was not shared, it was connected to the router and a wireless print server. To enable printing from all 'puters (a goal that could not be achieved according to one tech guy at a major chain) I configured to print to the IP. Works like a charm.

JimmyN
07-30-2010, 13:18
That's actually the easiest and best way to do it. A network printer eliminates the problem of having one OS accessing a printer being shared on another OS, and it always works regardless of the mix of operating systems you have.

I think most new printers now come with an ethernet port, so you don't even need a print server. Plus with a network printer you don't need to have a PC with the printer attached running all the time, since the printer is connected directly to the LAN.

Drjones
07-30-2010, 18:33
That's actually the easiest and best way to do it. A network printer eliminates the problem of having one OS accessing a printer being shared on another OS, and it always works regardless of the mix of operating systems you have.

I think most new printers now come with an ethernet port, so you don't even need a print server. Plus with a network printer you don't need to have a PC with the printer attached running all the time, since the printer is connected directly to the LAN.


This.

Also, look very carefully before you buy - if you're going to get a new printer - to see how it works. HPs seem to work quite well with no real monkeying around, other printers require you to login to your router & set a static IP for the printer.

Generalcarry
08-11-2010, 04:30
Some family problems arose and messing with a printer took the backseat.
I did get the printer working on the Linux, but when I started messing with the scanner (print/scan) I messing something up so I'm back at square one. I'm pretty confident I'll get the Linux going again but it's the MS Win. 7 64 bit machine (which probably should be the easiest) that I never go to print. I just found out the "bi-directional" box re-checked itself(?) but I cleared that up and going to try it again.
In reality, my biggest problem are the acronyms, synonyms and vocab in general. I need to google quite often.:dunno:

IndyGunFreak
08-11-2010, 07:36
I'm a Linux neophyte and the only one using the computer so I must be, unless, you have to specify the fact you are the root/super user.
i

While I'm not familiar with your printing problem, Ubuntu uses sudo, so if you do something that requires root privileges, it will tell you you need to be root, and make you enter your password, this of course, assumes you've not opened something w/ sudo in the last few minutes.

A print server would make this a lot easier, and they aren't that expensive(this of course, assumes you have a free port on your router).

http://www.tigerdirect.com/applications/SearchTools/item-details.asp?EdpNo=2974622&CatId=371

IGF