P250 - light primer strikes - mystery solved [Archive] - Glock Talk

PDA

View Full Version : P250 - light primer strikes - mystery solved


PVanCleave
09-13-2010, 20:17
I now have two P250s. One of them suddenly starting having problems with light primer strikes that got worse to the point that every 2 or 3 rounds would be a misfire until I pulled the trigger again. Sometimes it would take 2 additional hits.

After comparing that 250 with the one that didn't have a problem, I finally figured out exactly what was happening:

The hammer was falling off the trigger bar way too soon. It was only going back half the distance it was supposed to. If I pulled back **ever** so slightly on the slide, then the hammer went the full distance.

Bottom line: the trigger bar was not getting a good purchase on the hammer and would slip off prematurely causing a light primer strike. By moving the hammer slightly more to the rear, the trigger bar could get a firm purchase and would move the hammer the full distance before releasing it, giving a good primer strike.

A couple of days ago my other P250 started doing the same thing. :crying:

Both are back for repair.

This sounds like perhaps some defective parts. Hopefully not a defective design.

When I get the guns back, I am really going to put them through their paces.

Maine
09-15-2010, 10:32
What size and caliber P250 did/do you have?
Is it newer frame style with the cut-out on the grip?

I had a P250 sub compact in 9mm that was unstoppable through the 1,300 or so rounds I fired from it before trading it. Just curious, Thanks

PVanCleave
09-15-2010, 11:37
What size and caliber P250 did/do you have?
Is it newer frame style with the cut-out on the grip?

I had a P250 sub compact in 9mm that was unstoppable through the 1,300 or so rounds I fired from it before trading it. Just curious, Thanks

Both are the new style subcompact .40 S&W. Never had an issue with FTF, FTE, or any other stoppage. Accuracy is great. Just this one bad problem. Both showed up after several hundred rounds.

rfd339
09-17-2010, 18:37
I have read a lot threads on this and hope they fix it for you. Glad you found the issue.

PVanCleave
09-17-2010, 18:41
I have read a lot threads on this and hope they fix it for you. Glad you found the issue.

Thanks - the first gun came back today. I went to the range (after first dry firing it with a snap cap about 200 times). Shot 250 rounds and it worked perfectly, with the hammer coming fully back on each shot.

rfd339
09-17-2010, 19:13
Good to hear.:thumbsup:

PVanCleave
09-22-2010, 23:38
The second gun came back, and it too works like a top. 200 dry-fires and 150 shots at the range today.

Kudos to Sig for great customer service.

On the first gun they replaced the trigger bar. On the second they "upgraded" the trigger group.

Maine
10-06-2010, 00:49
The second gun came back, and it too works like a top. 200 dry-fires and 150 shots at the range today.

Kudos to Sig for great customer service.

On the first gun they replaced the trigger bar. On the second they "upgraded" the trigger group.
Good deal. Enjoy