Torn Brass [Archive] - Glock Talk

PDA

View Full Version : Torn Brass


headblade
09-13-2010, 21:45
Heya Fellas. I got my KKM 6" and 22# Wolff Recoil Spring w/steel guide rod for my G-20 today. Christmas in September! Did some workups with some IMR 800-X using CCI-300 and Zero 180 FMTC and virgin Starline Brass. Started with 9.0 grains and ended the session with 9.6 grains. As far as I could tell using about 3 or 4 sources 9.6 grains is at Max or below so should be within Specs. Man whata blast I had. No noticable pressure signs at all and achieved an average of 1374 FPS 5 shot using the 9.6 gr. I would have had a stiffy with just 1350 and still below max, but 1374?:supergrin: The only one problem I had was my very last shot of the day, last round in the magazine got torn at the mouth somehow. I suspect it somehow got lodged between the slide and the back end of the mag. It ejected about 2 feet straight up and fell to my feet. No damage to anything other than the brass. The slide locked back to the rear like it is supposed to with the last round and everything. Was weird as hell. Hopefully it was just a fluke 1 in a million time thing. I dunno it may have something to do with my 22# recoil spring or sumfin. Any experiences you all have had will be great if shared. I will try and post a pic on here if I can figure out how. Oh wait, how do you do that? lol

Wow that was quick. I made an account at Photobucket. This SHOULD work. http://s912.photobucket.com/albums/ac330/headblade7/

_The_Shadow
09-16-2010, 12:01
It looks like the brass din't get kicked off the extractor by the ejector and as the slide returned home, the case mouth hung on the magazine feed lips. Inspect the feed lips for roughness, compare to other magazines as well.

Things to check would be...
Chech the extractor rim of the suspect brass...I have seen some which were too thick(by this I mean they will not fit in to my RCBS shell holder for press), if this is the case it may have got hung up on the extractor. Some extractors get bent or out of spec can hold the case rimm too tightly.

Try factory ammunition for proper function, with the factory recoil spring/rod...if it functions correctly, then try the other spring and guide rod for function with factory ammo. If this function is correct, move on to possible bent or broken ejector...compare to one from another pistol which is correct and working.

It could be the impulse of your handloaded ammunition which is causing the slide to over run, in combination with the recoil rod. Its hard to pin point just what is happening without seeing it actually happening. This is why you may have to do a process of elimination just to see.

Good luck!

headblade
10-02-2010, 19:34
Oh hey. Almost forgot I posted this. Thanks for your reply Shadow. You are very helpful on here it seems. I havn't had any more torn brass after a couple hundred more rounds so I'm hoping it was just a fluke. I did change the recoil spring to a 20# instead of 22# tho, so maybe that did help. Thanks again bud.