Having problems with my mossberg [Archive] - Glock Talk

PDA

View Full Version : Having problems with my mossberg


dc2integra
11-29-2010, 19:35
im new to shotguns i purchased a mossberg 500 a few months ago ihave put about 300 rounds through it.I have had it jam on me about 5 times.The shell will be in the chamber ready to go and pull the trigger but nothing the forend was all the way forward all the time s too.Coud it be that i half racked it those few times that failed on me.I also had a friend shoot it and the same happened to him.Ive shot a few shotguns before and have never experienced this.Any help will be appreiated

collim1
11-29-2010, 20:15
need more info to be sure

was the primer dented?
happen with more than one type of ammo?

TexasNativeDRJH
11-29-2010, 20:23
Mine sometime jams with cheap birdshot.. Do you have a side saddle installed? Another jamming issue I had involved the replacement ejector screw for a side saddle. I ground the head down a little and no more problems

mixflip
11-29-2010, 21:46
I know this isnt the problem your having but I figured I 'd share a 590 story. My old 590 developed a weak safety button spring. This caused the gun to put itself on safe after ever shot so my 2nd shot would not fire.

Back on topic, maybe your problem is a bad firing pin or its the ammo? I am no armorer but that would be the first place I'd look???

dc2integra
11-30-2010, 15:51
Mine sometime jams with cheap birdshot.. Do you have a side saddle installed? Another jamming issue I had involved the replacement ejector screw for a side saddle. I ground the head down a little and no more problems
It does only happen when i use cheap birdshot.I buy the 100 round winchester pack for 20$ at walmart.But my brother also has a mossberg 500 but an older model he bought like 7 years ago and it has never jammed on him and he also uses the cheap birdshot.I also noticed that when the forend is racked all the way the "elevator" sticks out about a 1/4 inch

dc2integra
11-30-2010, 15:53
Im gonna try to compare mine with my brothers this weekend and see if I the elevator sticks out on his that far out

dc2integra
11-30-2010, 16:41
repost

vafish
11-30-2010, 19:13
You could be short stroking it and not setting the hammer back.

Make sure you slam it all the way back and then all the way forward. You don't need to baby them.

Edited to add:

I don't think it's short stroking, if by "nothing" you mean you aren't even hearing a click. I just pulled my 500 out and it resets the hammer with less then half a pump.

dc2integra
11-30-2010, 21:15
when I rack the forend back when it starts getting to the end it gets to a certain spot then it get s a little harder if you dont put some force on it ,it wont eject the cartridge

dc2integra
11-30-2010, 21:18
Mine sometime jams with cheap birdshot.. Do you have a side saddle installed? Another jamming issue I had involved the replacement ejector screw for a side saddle. I ground the head down a little and no more problems
its all stock from the factory.

bel970
11-30-2010, 23:33
I'd guess that the failure to fire is because you are not returning to battery and the the trigger disconnect is still engaged, may be related to the cheap ammo or could be that you just need to be a little rougher with it. It's not unheard of to have issues with cheap 12g ammo especially with newer guns. could also be that it needs a good cleaning, may be that the factory lube (formulated for long term storage not for functioning firearms) has collected enough fouling to gum the works up.

I suspect that the hangup before ejection is just the shell contacting the ejector and the inside extractor being pulled over the rim combined with the fact it is new and there is a lot stuff going on at the end of the stroke, the ejector has a lot of tension on the bolt as it slides out and the elevator gets kicked down all at the same time. 500s are not known to be smooth operating, at least not until they get a good round count on them.