G37 with ejector issue [Archive] - Glock Talk

PDA

View Full Version : G37 with ejector issue


sa227driver
12-05-2010, 17:37
JR,

I picked up a slightly used G37 from a LEO friend of mine. When I bought it from him he said that it would probably need a new recoil rod/spring. So I bought a factory new one from Glockmeister.com and installed it. Some issues I have been having are casings that get jammed trying to eject and make a "smoke stack" out of the top of the ejector port and some times fail to eject completely. Could this be rectified by simply wearing in my new recoil spring by leaving the slide open for about a week and try it again? Thanks for any info that you may have.

-Brett

JR
12-18-2010, 16:53
I suspect you have an increased weight recoil spring. Is it aftermarket or factory? You got a pic?
You also may be limpwristing the pistol. Are you an experienced Glock shooter?

sa227driver
12-19-2010, 15:22
I suspect you have an increased weight recoil spring. Is it aftermarket or factory? You got a pic?
You also may be limpwristing the pistol. Are you an experienced Glock shooter?

The recoil spring/rod is a factory spring/rod I bought from Glockmeister.com and it is stamped with a 5### on the end of it. My other Glock is a 19 and so I think I just need to get used to a full size Glock along with the bigger caliber. I recently took out the GAP again this past weekend and out of 100 rounds of WWB only one created a "stove pipe". So I think I'm getting better with my grip. Thanks JR!

JR
12-19-2010, 17:09
I can pretty much guarantee you are creating the problem by limp wristing. Practice makes perfect!