SureFire x300 not fitting on G21 3Gen [Archive] - Glock Talk

PDA

View Full Version : SureFire x300 not fitting on G21 3Gen


jstaylor62
01-16-2011, 06:20
I just bought a x300 for my G21. When I try to slide the light onto the rail, it does not lock into place. The locking tab in the light is still forward of the slot on the frame when the light is pushed all the way against the front of the trigger guard. Is this common?

DannyR
01-16-2011, 07:00
Are you trying it with or without the Picatinny rail adapter that was include?

jstaylor62
01-16-2011, 10:12
Are you trying it with or without the Picatinny rail adapter that was include?

Neither the P or U plate are working. Both tabs are still forward of the slot on the frame when I slide the light all the way back against the trigger guard.

DannyR
01-16-2011, 16:34
I suggest you contact Surefire tomorrow and explain your problem.

RayB
01-16-2011, 17:21
I just bought a x300 for my G21. When I try to slide the light onto the rail, it does not lock into place. The locking tab in the light is still forward of the slot on the frame when the light is pushed all the way against the front of the trigger guard. Is this common?


Bummer! :frown:

Our SureFire X200's A & B locked up just fine, right out of the box, on our 3rd Gen G17, G19 & G21... And I could swear I've read cases of other GT members mounting the X300 onto a Gen 3 G21... :headscratch:

This makes me wonder if Glock made a running change in the latter Gen 3's or something? Or, did SureFire make a running change to the X300? :dunno:

At any rate, SureFire's a class act, and they will take care of you! :thumbsup:

Let us know what they say, okay? :wavey:

--Ray

TSAX
01-17-2011, 04:30
I suggest you contact Surefire tomorrow and explain your problem.

Yep, my surefire worked fine with my Glocks. Maybe the attachment you got was a bad cut. It can happen. Call them and ask if they can send you new attachments, that should help. I use that little allen tool and take the screws off to change attachments for different guns and it got annoying so I bought 2 lights. One that fits my Glocks perfect and one that fits my other guns.

jstaylor62
01-18-2011, 08:06
I suggest you contact Surefire tomorrow and explain your problem.

I got an email back from SureFire. They said this was a known issue. They said it is caused by the O-Ring on the battery cover. The O-Ring needs to be compressed and broken in a little before the light will slide back far enough and lock into place. I compressed the O-Ring by using a clamp for a few hours and it worked like a champ.

silvrevo
01-18-2011, 09:28
I just put an x300 on my G19,,, it didnt click in or lock in place,,, rather fit really snugg?

I wasnt sure if it locked in or not? But it isnt going anywhere. I just press the tab on the x300 to slide off. then just slide it on,,, I dont hear any cliking/locking into place.

JRS
01-18-2011, 15:59
I just put an x300 on my G19,,, it didnt click in or lock in place,,, rather fit really snugg?

I wasnt sure if it locked in or not? But it isnt going anywhere. I just press the tab on the x300 to slide off. then just slide it on,,, I dont hear any cliking/locking into place.

It should click. Try loosening the 6 screws that hold the 2 light brackets on and see if you can get it to click into place. Then retighten them after

RayB
01-18-2011, 16:20
I got an email back from SureFire. They said this was a known issue. They said it is caused by the O-Ring on the battery cover. The O-Ring needs to be compressed and broken in a little before the light will slide back far enough and lock into place. I compressed the O-Ring by using a clamp for a few hours and it worked like a champ.


Ah! Good info! :thumbsup:

I wonder, is water-tight integrity affected by doing this? :eyebrow:

--Ray

jstaylor62
01-18-2011, 16:35
It should click. Try loosening the 6 screws that hold the 2 light brackets on and see if you can get it to click into place. Then retighten them after

What you are suggesting will not move the position of the tab on the "U" or "P" plate. That plate is attached to the light by a pin on top of the light.

RayB
01-18-2011, 16:40
I've something related to add... :eyebrow:

Notice how the back of the X300 snugs right into the curve of the Glock trigger guard, like it was made for it? Pretty neat, huh? ;)

While I appreciate the SureFire's great fit, I found that trying to mount an X200 A or B beneath a LaserMax Uni-Green, rail-mounted laser, didn't work because the light was too long to achieve lock up when attached to the laser, which has its own integrated rail. :sigh:

This will no doubt be true with the X300 as well, since its exterior specs are about the same... :whistling:

--Ray