Firefox slowing down? [Archive] - Glock Talk

PDA

View Full Version : Firefox slowing down?


kirklite99
01-23-2011, 00:11
I'm running the latest version and it keeps slowing down the longer I use it until I completely close it. I know there were memory leak problems with previous versions, but I thought they fixed that. Any ideas? Other than that, my computer runs great. No viruses, registry errors, extraneous BS, etc...

alphacat
01-23-2011, 01:28
I've noticed the slow down myself.
Don't know why that is, maybe someone on here does.

kirklite99
01-23-2011, 02:57
I know... It's irritating when you click on another tab and it takes forever to switch over.

alphacat
01-23-2011, 03:31
It sure is. Mine keeps crashing and I have to restart it.

TBO
01-23-2011, 09:30
Much love for FF, but it's been surpassed, performance wise, but Google Chrome.

I still have FF on my box, but haven't used it other than check and see if new updates have improved performance (no they haven't).

I use Google Chrome almost exclusively (dabbled with Opera a few months back, but Chrome is king once again).

JFrame
01-23-2011, 10:24
I switched to FF 4.0 Beta, found it still a hair too unstable, and switched back to FF 3.x. I'm currently running 3.6.13.

Honestly, I'm not seeing the slow-down of which some of you speak. :dunno:


.

kirklite99
01-23-2011, 10:35
I switched to FF 4.0 Beta, found it still a hair too unstable, and switched back to FF 3.x. I'm currently running 3.6.13.

Honestly, I'm not seeing the slow-down of which some of you speak. :dunno:


.

I'm running the same version. I don't shut my computer down entirely very much and usually just "put it to bed" in standby for a quick start-up. I find at least once a week I have to shut Firefox down and watch the memory "come back" in task manager. Then I re-open it and everything is fine for a few days. Weird... I do keep at least 10, and sometimes up to 20, tabs open at once, but that shouldn't matter.

JFrame
01-23-2011, 10:42
I'm running the same version. I don't shut my computer down entirely very much and usually just "put it to bed" in standby for a quick start-up. I find at least once a week I have to shut Firefox down and watch the memory "come back" in task manager. Then I re-open it and everything is fine for a few days. Weird... I do keep at least 10, and sometimes up to 20, tabs open at once, but that shouldn't matter.

I'm sorry to hear about the trouble you've been experiencing. :frown:

Just a stupid question -- did you trying uninstalling FF and doing a reinstall?

I find that software can get very tricky depending on the firmware and configurations of any given machine. I know that some software has given me fits that others use with no problems.


.

Glockdude1
01-23-2011, 10:44
I am using FF and experiencing no problems.

:cool:

GIockGuy24
01-23-2011, 14:56
It can happen when certain add-ons / plug-ins automatically update are updated without uninstalling the older versions. Click "Tools" than click "Add-ons" and then uninstall all of them. You can write them down first if they are special add-ons but if they common ones that ask to install while surfing the internet it's not required. Also in "Add / Remove Programs" uninstall Adobe Flash Player and Java if it shows more than one version installed. Flash Player is usually the problem though.

kirklite99
01-23-2011, 15:11
Also in "Add / Remove Programs" uninstall Adobe Flash Player and Java if it shows more than one version installed. Flash Player is usually the problem though.

I have Adobe Flash Player 10 Active X and Adobe Flash Player 10 Plugin. Do I need both of those?

GIockGuy24
01-23-2011, 15:19
I have Adobe Flash Player 10 Active X and Adobe Flash Player 10 Plugin. Do I need both of those?

I believe one is for Internet Explorer and one is for "other" internet browsers. If you use something other than I.E. you can uninstall both of them and just install the one for other browsers.

Here is a link

http://filehippo.com/download_flashplayer_firefox/8674/

The download is on the upper right side of the screen.

For IE

http://filehippo.com/download_flashplayer_ie/8673/

If you go to Adobe's website it will automatically detect which browser you are using, I think it will anyway. I'd get the non-IE download at Filehippo though.

http://www.adobe.com/products/flashplayer/

http://get.adobe.com/flashplayer/

MySiK26
01-23-2011, 15:32
Like TBO, I use Chrome exclusively. :cool:

swinokur
01-23-2011, 15:48
My version does the same thing. I have to shut it down and restart it.

kirklite99
01-23-2011, 17:03
Like TBO, I use Chrome exclusively. :cool:

I tried it and had problems (like many others did...I researched it) with not being able to print from Yahoo and read Hotmail because of Google's beef with Microsoft. Also, talk about a resource hog. :upeyes:

gemeinschaft
01-23-2011, 22:47
Try this:

Type "About:Config" in the address bar and press enter.

Accept the warning and continue.

Scroll down to "Network.http.pipelining" right click and toggle to "True"

Set "Network.http.pipelining.maxrequests" to 30 by right click and selecting Modify.

Toggle "Network.http.proxy.pipelining" to True

Right click and select "New" --> "Integer"

Name it "nglayout.initialpaint.delay" and enter value "0"

Close Firefox and reopen.

Obi Wan
01-25-2011, 15:18
Try this:

Type "About:Config" in the address bar and press enter.

Accept the warning and continue.

Scroll down to "Network.http.pipelining" right click and toggle to "True"

Set "Network.http.pipelining.maxrequests" to 30 by right click and selecting Modify.

Toggle "Network.http.proxy.pipelining" to True

Right click and select "New" --> "Integer"

Name it "nglayout.initialpaint.delay" and enter value "0"

Close Firefox and reopen.
OK, 'Fluffy', I've done it. Will my machine blow up on me tonight? :supergrin:

Thanks... we'll see what happens! :whistling:

gemeinschaft
01-25-2011, 15:22
OK, 'Fluffy', I've done it. Will my machine blow up on me tonight? :supergrin:

Thanks... we'll see what happens! :whistling:

Is there any change?


The other culprit sometimes can be a problem with an Add-on to Firefox. The best way to figure out if this is an issue is to disable your add-ons and then see if the problem still exists.

If your problem is fixed with all of your Add-ons disabled, then one by one enable them starting with the ones that you use most. If you can narrow down which one is causing the issue, then simply get rid of it or reinstall it.

Obi Wan
01-25-2011, 15:58
I haven't had a chance to close down and reboot yet. Will do it later.

When my system bogs down, I clean up with ATF and Crap Cleaner, run Avira every night, and occasionally run AntiMalware. Did find some trojans last month, but a reboot usually clears things up for awhile.

Haven't located a particular add-on yet that's guilty.

gemeinschaft
01-25-2011, 16:02
I haven't had a chance to close down and reboot yet. Will do it later.

When my system bogs down, I clean up with ATF and Crap Cleaner, run Avira every night, and occasionally run AntiMalware. Did find some trojans last month, but a reboot usually clears things up for awhile.

Haven't located a particular add-on yet that's guilty.

The changes that you make in the about:config screen will not take place until after you close Firefox and then open it again.

Let me know if you experience anything different - this is how I configure all my PCs.

kirklite99
01-25-2011, 17:20
What pisses me off the most is when I try to click on another open tab and it takes 5+ seconds to switch over. That's when I know things are going to hell... :upeyes:

JimmyN
01-26-2011, 14:46
Setting the max number of pipeline requests to 30 doesn't do anything, even though you frequently see that listed as a "speed tweak" all over the internet. Sometimes you'll see recommended values as high as 128. But Firefox is hard coded for a maximum of 8 so there is no point in going above that, values above 8 are just ignored. The servers are not going to let you hammer them with 8 simultaneous requests from a single socket anyway, much less 30, so the additional requests will be dropped and have to be sent again, actually slowing things down.

Pipelining is not multiple connections to a server, it's multiple requests placed in the same packet. 'GET' and 'HEAD' requests can be piped together, but 'POST' and 'PUT' requests will not be piped anyway, regardless of your settings.

How much you benefit from pipelining is dependent on bandwidth and latency. If you have a high latency connection then putting as many requests as possible in one TCP/IP packet reduces the number of packets that have to be sent, and responded to. Even a value of 2 will cut the number of requests that have to be sent in half. But a low latency connection has such a fast round trip time that pipelining doesn't provide as much of a speed increase over single requests.

If you have pipelining set to 30 Firefox will sent 8 requests to the server in the same packet. If the server only handles the first 2, then Firefox will have to resend 6 from the last request when it makes it's next request. And it won't send another request until it hears back regarding all 8 of the previous requests since they were all sent piped together in one packet.

The HTTP 1.1 spec requires that the server be able to handle pipelined requests, but it doesn't have to provide a given number or even provide any pipelining at all. The spec just says the server can't fail due to receiving a piped request. Using an 'onload' event handler to time page loads I have found that 4 seems to be the best all around setting for fastest page rendering. I doubt it's a coincidence that Firefox uses that as the default value. But pipelining is turned off by default since it can cause problems fetching pages from servers that are not HTTP 1.1 compliant, so you'll have to set it to 'true' manually in the 'prefs.js' file or using 'about:config'. Just turning on pipelining will speed things up for many websites, but setting max requests to 30, or even 8, will negate some of the speed improvement gained by using pipelining, since many file requests will have to be re-sent repeatedly.


Setting 'nglayout.initialpaint.delay' to '0' is another "speed tweak" you frequently see on the internet that actually slows down page rendering. The delay value tells Firefox how long to wait for requested files before starting to render the page. If there is no delay set it will start to calculate the page layout as soon as the first script is received. Of course the layout will change as the image and object files come in because they'll need space. But since you deprived it of the 1/4 second default delay so it would have something to work with, it likely started with just the script before any of the larger files arrived and it is now busy pointlessly calculating page layout and flow for the text that it will have to redo as soon as it's finished.

You're more likely to get better performance by increasing the delay value rather than decreasing it. Setting the delay to 1/4 second or more will allow time for the browser to receive enough files to actually accomplish something on the first pass. If setting the delay to '0' actually resulted in the fastest page rendering I think it's safe to assume that Mozilla would have used that value as the default.

If you prefer the perception of speed that Chrome provides.... that momentary pause and then the page 'pops' up almost all at once.... then set your delay to 1000 (1 second), which seems to be in the range that Chrome uses, or even go to 1500. With a fast connection and a 1~1.5 second delay the browser will likely have most or all the files cached at that point and can render the page in just one or maybe two passes very quickly.

Perception is different from reality. Setting the delay to '0' may appear to speed up pages as you see something happen immediately on the screen. But increasing the delay to 1/4~1/2 second will actually decrease page rendering time, and increasing it to 1~1.5 seconds will provide the momentary pause followed by the complete page popping up as you see in Chrome.

You can test the delay setting for yourself. Set it to '0', then clear the cache so Firefox doesn't pull any files from there. Click on a link and time it till the page is complete. Go back and set the delay value to 1000, clear the cache, and then time the page again. You will be more impressed with the '1000' value than you are with the '0' value.

Obi Wan
01-26-2011, 15:35
Great info, Jimmy! I only partly understand the tech talk, but I've made the following changes to try it...


Type "About:Config" in the address bar and press enter.

Accept the warning and continue.

Scroll down to "Network.http.pipelining" right click and toggle to "True"

Set "Network.http.pipelining.maxrequests" to 4 by right click and selecting Modify.

Toggle "Network.http.proxy.pipelining" to True

Right click and select "New" --> "Integer"

Name it "nglayout.initialpaint.delay" and enter value "500"
Do those two changes make sense?

Close Firefox and reopen.

gemeinschaft
01-26-2011, 15:47
Setting the max number of pipeline requests to 30 doesn't do anything, even though you frequently see that listed as a "speed tweak" all over the internet. Sometimes you'll see recommended values as high as 128. But Firefox is hard coded for a maximum of 8 so there is no point in going above that, values above 8 are just ignored. The servers are not going to let you hammer them with 8 simultaneous requests from a single socket anyway, much less 30, so the additional requests will be dropped and have to be sent again, actually slowing things down.

Pipelining is not multiple connections to a server, it's multiple requests placed in the same packet. 'GET' and 'HEAD' requests can be piped together, but 'POST' and 'PUT' requests will not be piped anyway, regardless of your settings.

How much you benefit from pipelining is dependent on bandwidth and latency. If you have a high latency connection then putting as many requests as possible in one TCP/IP packet reduces the number of packets that have to be sent, and responded to. Even a value of 2 will cut the number of requests that have to be sent in half. But a low latency connection has such a fast round trip time that pipelining doesn't provide as much of a speed increase over single requests.

If you have pipelining set to 30 Firefox will sent 8 requests to the server in the same packet. If the server only handles the first 2, then Firefox will have to resend 6 from the last request when it makes it's next request. And it won't send another request until it hears back regarding all 8 of the previous requests since they were all sent piped together in one packet.

The HTTP 1.1 spec requires that the server be able to handle pipelined requests, but it doesn't have to provide a given number or even provide any pipelining at all. The spec just says the server can't fail due to receiving a piped request. Using an 'onload' event handler to time page loads I have found that 4 seems to be the best all around setting for fastest page rendering. I doubt it's a coincidence that Firefox uses that as the default value. But pipelining is turned off by default since it can cause problems fetching pages from servers that are not HTTP 1.1 compliant, so you'll have to set it to 'true' manually in the 'prefs.js' file or using 'about:config'. Just turning on pipelining will speed things up for many websites, but setting max requests to 30, or even 8, will negate some of the speed improvement gained by using pipelining, since many file requests will have to be re-sent repeatedly.


Setting 'nglayout.initialpaint.delay' to '0' is another "speed tweak" you frequently see on the internet that actually slows down page rendering. The delay value tells Firefox how long to wait for requested files before starting to render the page. If there is no delay set it will start to calculate the page layout as soon as the first script is received. Of course the layout will change as the image and object files come in because they'll need space. But since you deprived it of the 1/4 second default delay so it would have something to work with, it likely started with just the script before any of the larger files arrived and it is now busy pointlessly calculating page layout and flow for the text that it will have to redo as soon as it's finished.

You're more likely to get better performance by increasing the delay value rather than decreasing it. Setting the delay to 1/4 second or more will allow time for the browser to receive enough files to actually accomplish something on the first pass. If setting the delay to '0' actually resulted in the fastest page rendering I think it's safe to assume that Mozilla would have used that value as the default.

If you prefer the perception of speed that Chrome provides.... that momentary pause and then the page 'pops' up almost all at once.... then set your delay to 1000 (1 second), which seems to be in the range that Chrome uses, or even go to 1500. With a fast connection and a 1~1.5 second delay the browser will likely have most or all the files cached at that point and can render the page in just one or maybe two passes very quickly.

Perception is different from reality. Setting the delay to '0' may appear to speed up pages as you see something happen immediately on the screen. But increasing the delay to 1/4~1/2 second will actually decrease page rendering time, and increasing it to 1~1.5 seconds will provide the momentary pause followed by the complete page popping up as you see in Chrome.

You can test the delay setting for yourself. Set it to '0', then clear the cache so Firefox doesn't pull any files from there. Click on a link and time it till the page is complete. Go back and set the delay value to 1000, clear the cache, and then time the page again. You will be more impressed with the '1000' value than you are with the '0' value.


:bowdown::bowdown::bowdown:

kirklite99
01-26-2011, 15:51
I disabled the Ad/pop up Block and Flash Block add-ons, or whatever they're called. Seems to have fixed it as I don't see my available memory in Task Manager draining away like I did before. Strange thing is I still don't see any ads or popups. Well, except for the BS ones here at the bottom, but I don't think you can do anything about it and it's not that big of a deal anyway...

JimmyN
01-28-2011, 09:46
Do those two changes make sense?



Makes sense to me.

Sorry I didn't respond sooner, yesterday was just one of those days with 100 brush fires to put out. And to top it off my "the needles been on the red line before and I didn't run out" daughter called because she had run out of gas so I had to go rescue her. But the last of the flames are out this morning and I broadcast a company email that I was rotating backups today, so they won't bother me unless it's an emergency. All I have to do is start a few scripts running and then go do whatever I want, but they seem to think I have to sit here and turn a crank or something the whole time, I have no idea how they got that impression:supergrin: So now I have time to ramble on with some more meaningless drivel that you probably didn't want to know anything about anyway.

Most of the problems with Firefox come from extensions or Flash. It's an extensible browser and you can keep it lean right out of the box or go for fully loaded and drag a lot of baggage around with you. But there are thousands and thousands of extensions available and there is no way to check cross compatibility due to the million different combinations that are possible.

If you are slow switching tabs and using the Firecookie extension try disabling that, as it will slow it down. It could also come from not enough memory cache causing a pause as Firefox dynamically changes the cache size when you change tabs. But it could also come from conflicting extensions. If you have more than 39 tab related extensions installed, that's likely your problem:supergrin:

You could try increasing your browser memory cache to a set value, rather than Firefox constantly playing with the size. This would tend to help more if you typically have a lot of tabs open. The browsers memory cache contains information on pages in the tabs and pages you have visited making the response quicker when changing tabs or backing up. Firefox used to use a hard value but now allocates cache memory dynamically with a starting value based on your systems RAM. If it doesn't have room to store the tab you're in when leaving it for another tab you will have some delay as it increases cache size to store the tab, or gets rid of older pages it has stored for your 'Back' function.

This is not the same as the disk cache. The disk cache is where it stores the actual files received from the server, memory cache contains information about he page itself.

Prior to Version 2 if you had 2gigs of memory it would allocate 45KB to memory cache. With dynamic allocation and 2gigs of system memory it now only starts with 24KB and adjusts it upward when it needs more, and it will, so you get some delay every time it decides to adjust memory up or down and shuffles things around. I prefer to set a hard value so it doesn't spend time making decisions and changes.
You'll have to create a new integer value in 'about:config'. so you can override the default.
Name it browser.cache.memory.capacity
Enter a value in KB, but keep it on a 1024 boundary.
So maybe 45056 for 2 gigs, 59392 for 4gigs, or 75776 for 8gigs, those used to be the default values before they switched to dynamic allocation.
You can use any value you want, just make sure it's a multiple of 1024.

Since browser reviewers compare memory usage to see which browser uses less Mozilla went to the low value with dynamic increases as you open more tabs, it looks better in the reviews, and it gives back memory when you close tabs. But that shuffling does take time. If I have even just 2gigs of memory I don't have any problem allocating at least 75KB of that for browser cache to help performance.
If it doesn't help and you want to go back to dynamic allocation delete the key or change the integer value to '-1'.

You can check your current disk and memory cache sizes, the number of items, and the number of fetches, by typing about:cache into the address line.

And if you've never done it before you can type in about:mozilla for a passage from the Book of Mozilla as it speaks of the complacency of Mammon (IE), the birth of Firefox from the ashes of Netscape, and the fall of IE from dominance, becoming just a follower.