Odd: X300 + M&P .45FS is a no go [Archive] - Glock Talk

PDA

View Full Version : Odd: X300 + M&P .45FS is a no go


Morris
02-12-2011, 19:00
Swapped out for the pic rail. Not joy in latching into place. Worked fine with the universal plus my G22G4 . . . Either the front of the trigger guard on the M&P is a shade to wide for the back plate on the X300 or the latch just isn't spec'ing into the rail slots correctly.

Thoughts? Input?

swinokur
02-13-2011, 06:33
Call Surefire CS. Best in the business IMO. They will get you straightened out.

Morris
02-13-2011, 08:25
Oh, they have done me well. Just checking to see if this is a fluke or something seen before.

bobelk99
02-13-2011, 16:32
Please let us know what they say. I have a spare X400 I have been considering buying a M&P for. Your post makes me wonder.

I may just get rid of the X400.

Morris
02-13-2011, 17:19
Yeah, I'll call tomorrow. Who knows, maybe the latch is slight out of spec or I'm just a dork on this one.

On a side note, my old ITI M6 slips on and latches in place just fine . . .

Palmguy
02-13-2011, 17:31
I seem to remember the X300 being extremely difficult on my M&P9; so much so that I went to the Insight Procyon.

RayB
02-13-2011, 17:41
Along similar lines, I found that my SureFire X200 A&B weapon lights would not achieve lock-up beneath a LaserMax LMS-UNI-G rail-mounted laser on our 3rd Gen G17, G19 or G21. The reason--the SureFire lamp body is too long, as it runs into the Glock's forward-curved trigger guard before lock-up can be achieved.

The simplest solution--a shorter-bodied weapon light. I found that the Insight XTI Procyon, with its shorter lamp body, locked up nicely. I'm sure the new WX150 would fit as well.

By the bye, the insight weapon lights give the SureFires a real run for their money, performance-wise too--at $100.00 less.

--Ray

RayB
02-13-2011, 17:42
I seem to remember the X300 being extremely difficult on my M&P9; so much so that I went to the Insight Procyon.


Great minds! :supergrin:

--Ray

BigLaw
02-13-2011, 17:46
It will fit. Just slide it back as far as it will go and then give it a good push from the front. I thought mine was messed up as well but it will snap in place. You can also loosen up the screws that hold the rail adapter on just a hair and try again.

Morris
02-13-2011, 18:29
Okay. Will try the tap tonight.

Morris
02-17-2011, 13:33
Ahh, makes sense now.

Finally got a chance to chat with CS. The instructions do not specify this but you use the Universal tab rather than the Pic tab. The pic tab is for things like rifle rails, etc. Once back to the Universal, all was good to go. Also figured out that pressing FORWARD on the switch is for temporary activation.

All good now!