Sig C3 slide problem [Archive] - Glock Talk

PDA

View Full Version : Sig C3 slide problem


Pete2674
03-12-2011, 15:16
Hello everybody newbie here. Got a sig c3 about a month ago. I put 300 rounds thru it and had about half a dozen jams and slide didn't lock back after emptying clip ( both clips) happened twice so far. Is this part of the breaking in of the gun. Or is it a problem that I need to call sig?

Nickpisp
03-12-2011, 15:30
Do you have any other mags you can try? Could be magazine related.

TSAX
03-12-2011, 15:54
Options

A. Keep firing about 200 more and if the problem persists........
B. Try new mags
C. If you call Sig and the F---king sh-tless customer service they may say its break in, the mag, ammo or you. I did have a few guns that were like this that after a few hundred rounds ran fine but your at 300 already. Try 200 more.
D. Call Sig and maybe you get someone nice and they will pay for all the shipping for warranty work like Springfield did for me.

Good Luck :wavey:

Pete2674
03-12-2011, 15:58
Thanx for the info. What mags do you guys recommend?

knedrgr
03-12-2011, 16:09
Wilson or Chip.

MD357
03-12-2011, 17:00
+1 on trying different mags.

GeorgiaRedfish
03-12-2011, 17:42
+1 on calling them mags.

TSAX
03-12-2011, 18:05
Chip Power 10's or the Wilson 47's, even if at the end of the day its not the mags, these are still the best 1911 mags.

lawdog734
03-12-2011, 19:28
In my sig I use Tripp mags. They work great. I would call sig about the issues, I have had no issueswith mine

ImpeachObama
03-12-2011, 20:19
Got oil?

Pete2674
03-12-2011, 21:50
Oil? Yes I keep my gun clean and well lubed. Just hoping it's the mags:dunno: