SA M1A Loaded Accuracy Issues [Archive] - Glock Talk

PDA

View Full Version : SA M1A Loaded Accuracy Issues


freedom790
03-27-2011, 15:11
I posted this in the MBR forum 5 days ago, doesn't seem many people frequent that side of GT. So I propose my question here, since it is applicable to long range shooting:

Ok, so I've finally found the load that works best in my SA M1A Loaded. Its shooting .68" groups at 100yds from a rest, out of a Sage EBR stock and Burris XTR-312 scope in Warne tactical rings. Problem is, this is from a cold barrel only. If I fire another shot within the next 30ish seconds, POI tends to go up about a half inch, and the next shot, another half inch, and so on. I only shoot 5 shots at a time, so I don't know how far it will keep going. But once I let the barrel cool, its right back on point of aim. Its using the medium weight national match barrel that it came with from SA. My question is, would a barrel swap to a Krieger or some such other brand alleviate my problem. I'd like to shoot 5 shot strings without the barrel whipping the rounds higher every shot. For the most part, cost is not an option, but this is just a range toy, not my issued weapon, and I'd like to stay with the EBR stock that I have. Without trimming away portions of the front of the stock, I can only fit up to medium weight profile barrels. I'm looking for consistent performance to 600 yds point, 800 yds area, at a minimum, which I believe it achievable, but so far only from a cold bore...

Zak Smith
03-29-2011, 11:56
I recommend finding a gunsmith with a proven track record building accurate M14's that do not have this problem, handing them your rifle and a pile of cash.

Or sell it any buy a .308 AR pattern rifle. They are more accurate for less money, and typically don't have this type of systemic problem.