First range trip with the SRP... [Archive] - Glock Talk

PDA

View Full Version : First range trip with the SRP...


wrx04
03-30-2011, 13:34
I managed to get my SRP commanche to the range for the first time today. It was a pretty quick trip, since i had an appointment i needed to make, but i was able to send 200 rounds through it. The ammo i used was WWB, Rem mega pack, and some mild and hot reloads.

First things first....i shot it like crap! Im not sure why. It could have been one of many factors.....not used to the shorter barrel, different sights, short trigger, standard grips, or maybe i was a little excited and my trigger control was off:dunno:

The gun definitely feels different than the trojan that ive been shooting for the past 6 months. I pulled out the STI and ran a mag through it to make sure it wasnt me, and i ended up with one ragged hole at 7 yards. The SRP seemed to be shooting a little high for some reason. I am gonna go back to the range tonight and shoot another 300 through it to see if i can get it straightened out.

Functionally, the gun did OK. I did have two FTE's (stovepipes)....wasnt paying attention what ammo it was with though. The other thing was it shot the brass straight back into my face a couple times. My STI never has done that before, so i will have to see if that problem persists. Also, the gun does NOT slingshot. The slidestop BARELY catches it. Its so close that i bet a slight polish of the slidestop would do the trick. Its too bad they dont make them to have the proper amount of slide travel.....just a little bit more travel would completely eliminate this.

I just put thin grips on the gun, so we'll see if that makes it feel a little more like what im used to shooting. I will update again after i get back from my 2nd trip to the range tonight. That should give about 500 through it. Im gonna try to put another 500 through it tomorrow as well. Im curious to see if there is a pattern with the FTE's.

Here are a few pics before and after the range, and one with the new esmeralda thin grips.

http://img577.imageshack.us/img577/4967/img1499k.jpg (http://img577.imageshack.us/i/img1499k.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

http://img827.imageshack.us/img827/3008/img1505sv.jpg (http://img827.imageshack.us/i/img1505sv.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

http://img861.imageshack.us/img861/6383/img1509e.jpg (http://img861.imageshack.us/i/img1509e.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

glock2740
03-30-2011, 13:45
Congrats! Good looking gun. :thumbsup:

wrx04
03-30-2011, 13:49
Congrats! Good looking gun. :thumbsup:

Thank you sir.

Quack
03-30-2011, 13:52
I managed to get my SRP commanche to the range for the first time today. It was a pretty quick trip, since i had an appointment i needed to make, but i was able to send 200 rounds through it. The ammo i used was WWB, Rem mega pack, and some mild and hot reloads.

First things first....i shot it like crap! Im not sure why. It could have been one of many factors.....not used to the shorter barrel, different sights, short trigger, standard grips, or maybe i was a little excited and my trigger control was off:dunno:

The gun definitely feels different than the trojan that ive been shooting for the past 6 months. I pulled out the STI and ran a mag through it to make sure it wasnt me, and i ended up with one ragged hole at 7 yards. The SRP seemed to be shooting a little high for some reason. I am gonna go back to the range tonight and shoot another 300 through it to see if i can get it straightened out.

Functionally, the gun did OK. I did have two FTE's (stovepipes)....wasnt paying attention what ammo it was with though. The other thing was it shot the brass straight back into my face a couple times. My STI never has done that before, so i will have to see if that problem persists. Also, the gun does NOT slingshot. The slidestop BARELY catches it. Its so close that i bet a slight polish of the slidestop would do the trick. Its too bad they dont make them to have the proper amount of slide travel.....just a little bit more travel would completely eliminate this.

I just put thin grips on the gun, so we'll see if that makes it feel a little more like what im used to shooting. I will update again after i get back from my 2nd trip to the range tonight. That should give about 500 through it. Im gonna try to put another 500 through it tomorrow as well. Im curious to see if there is a pattern with the FTE's.

Here are a few pics before and after the range, and one with the new esmeralda thin grips.

http://img577.imageshack.us/img577/4967/img1499k.jpg (http://img577.imageshack.us/i/img1499k.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

http://img827.imageshack.us/img827/3008/img1505sv.jpg (http://img827.imageshack.us/i/img1505sv.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)

http://img861.imageshack.us/img861/6383/img1509e.jpg (http://img861.imageshack.us/i/img1509e.jpg/)

Uploaded with ImageShack.us (http://imageshack.us)


because it needs a flat trigger :tongueout:

BlayGlock
03-30-2011, 13:53
Very nice sir!

bac1023
03-30-2011, 14:03
Looks great.

I love the SRP.

bac1023
03-30-2011, 14:03
because it needs a flat trigger :tongueout:

:animlol:

atl-g33
03-30-2011, 14:21
Nice looking SRP you got there.

R0CKETMAN
03-30-2011, 14:30
What mags are you using? It sure does look good

carguy2244
03-30-2011, 14:48
No slingshot, multiple FTFs, inaccurate, and bad ejections...

Sign me up.

wrx04
03-30-2011, 14:54
What mags are you using? It sure does look good

Using a bunch of different ones. Wilson, CMC, Kimber, ATC, and Baer. I have 17 mags.....i know for a fact the kimber ones cause trouble. Always have a FTFeed with my Trojan on the last round

wrx04
03-30-2011, 14:59
No slingshot, multiple FTFs, inaccurate, and bad ejections...

Sign me up.

Not sure where you got multiple FTF's, and i am 100% sure its not the gun that is inaccurate. :upeyes:

The ejections may or may not be a problem. The slingshot thing is there and isnt going away....it is what it is.

carguy2244
03-30-2011, 15:20
Not sure where you got multiple FTF's, and i am 100% sure its not the gun that is inaccurate. :upeyes:

The ejections may or may not be a problem. The slingshot thing is there and isnt going away....it is what it is.

FTEs...my bad.

R0CKETMAN
03-30-2011, 15:25
Functionally, the gun did OK. I did have two FTE's

No slingshot, multiple FTFs, inaccurate, and bad ejections...

Sign me up.

FTEs...my bad.

Two is not multiple. Try to read a little slower or quit skimming.

quantico
03-30-2011, 15:32
Two is not multiple. Try to read a little slower or quit skimming.

Actually multiple starts with two. I e more than one .

quantico
03-30-2011, 15:41
I would not make a lot of judgements based on the limited use. I dont own a baer but the starting tight thing is part of getting one. Clean , shoot , clean and lube and see what smoothes out. I had a springfield longslide that started out with issues , but settled in and has been perfect with zero failures of any kind for the last ten plus years. I hope things get goimg for you soon. Baer is a pro , he stands behind his guns.

Hokie1911
03-30-2011, 15:57
Man, that's a lot of variables (mags, ammo). Hope you get it figured out. That's a sweet pistola.

R0CKETMAN
03-30-2011, 16:03
Actually multiple starts with two. I e more than one .

Thanks Webster, you are correct. We call it a couple or two where I'm from..

In any case, I agree keep shooting. Two FTE out of the first 500 rounds of a new Baer, no surprise and it should work itself out. A slingshot guarantee would be sweet:supergrin:

GJ1981
03-30-2011, 16:13
It sure sucks having a high $ 1911 with issues off the bat, trust me, I know all too well lately.

Hopefully everything works out for you.

Quack
03-30-2011, 16:24
I managed to get my SRP commanche to the range for the first time today. It was a pretty quick trip, since i had an appointment i needed to make, but i was able to send 200 rounds through it. The ammo i used was WWB, Rem mega pack, and some mild and hot reloads.

First things first....i shot it like crap! Im not sure why. It could have been one of many factors.....not used to the shorter barrel, different sights, short trigger, standard grips, or maybe i was a little excited and my trigger control was off:dunno:

The gun definitely feels different than the trojan that ive been shooting for the past 6 months. I pulled out the STI and ran a mag through it to make sure it wasnt me, and i ended up with one ragged hole at 7 yards. The SRP seemed to be shooting a little high for some reason. I am gonna go back to the range tonight and shoot another 300 through it to see if i can get it straightened out.

Functionally, the gun did OK. I did have two FTE's (stovepipes)....wasnt paying attention what ammo it was with though. The other thing was it shot the brass straight back into my face a couple times. My STI never has done that before, so i will have to see if that problem persists. Also, the gun does NOT slingshot. The slidestop BARELY catches it. Its so close that i bet a slight polish of the slidestop would do the trick. Its too bad they dont make them to have the proper amount of slide travel.....just a little bit more travel would completely eliminate this.

I just put thin grips on the gun, so we'll see if that makes it feel a little more like what im used to shooting. I will update again after i get back from my 2nd trip to the range tonight. That should give about 500 through it. Im gonna try to put another 500 through it tomorrow as well. Im curious to see if there is a pattern with the FTE's.

Here are a few pics before and after the range, and one with the new esmeralda thin grips.


haven't we been through this before? Baer's are not "designed" to slingshot, so you are SOL on that unless you send it to a smith to cut the frame rails down to the proper dimension.

wrx04
03-30-2011, 17:52
Quack, i know its not "supposed" to slingshot.....ive heard some guys say their commanche did.

I just ran another 250 through it (right around 500 for the day). Its dirty as hell but i kept it lubed up good. It had two more FTE's this range trip too. Didnt have any brass shoot back at my face this time though. I used all factory remington mega-pack ammo this time.

I started to get a feel for the gun and my groups improved this outing, although i would pull a couple shots every once in a while. I definitely HATE the three dot night sights.....the rear ones are very distracting.

I am hoping to put another 500 through it tomorrow. I will let the FTE's slide for now, and chalk it up to "break-in", but if they keep happening tomorrow, that might not be a good sign.

Do you guys shoot one gun (5" vs 4.25") better than the other, or are you pretty consisten with both sizes?

Quack
03-30-2011, 17:56
some did and your's doesn't :tongueout:

i shoot them (5" vs. 4.25") pretty much the same.

wrx04
03-30-2011, 18:11
some did and your's doesn't :tongueout:

i shoot them (5" vs. 4.25") pretty much the same.

Haha. Yeah that kinda sucks, but even the ones that do still have the jacked up dimensions. I'm pretty sure a smith could make mine slingshot very easily just by polishing the slide stop, but its the decreased slide travel that is the underlying issue. This has me thinking.....what if the decreased slide travel isnt giving quite enough time for the case to clear the slide causing the fte's. Hmmm.

I'm gonna keep shooting this one and we'll see if it works itself out. I really like the gun, and hope the reliability gets to where it should be (perfect). Time will tell.

Quack
03-30-2011, 18:13
~$150 and a trip to a smith will fix it for you.

wrx04
03-30-2011, 18:17
I may go that route if the issues continue....hell, i may do it regardless. I think it was severns that said he's done it many times and its a pretty easy fix.

Hokie1911
03-30-2011, 18:22
Send it back to Les and tell him what it's not doing. No wait....check that. He will just tell you to stick it up your ass and slingshot that. :rofl:

Chocobo
03-30-2011, 18:23
I don't understand why a gun that is designed to be carried cannot be slingshot. To me slingshot gives that extra little more energy to chamber the round reliably and its more of a universal move. But anyway, shoot some more and break it in.

wrx04
03-30-2011, 18:25
:rofl:
I should call him just to hear how he reacts.

Hokie1911
03-30-2011, 18:26
:rofl:
I should call him just to hear how he reacts.

Word of advice......speakerphone....voice recorder. :wavey:

Chocobo
03-30-2011, 18:30
:rofl:
I should call him just to hear how he reacts.

That would be a good idea before you had a gunsmith work on it because if might void the warranty if Baer has one.

Cobra64
03-30-2011, 18:32
Congrats! :cool:

WWB is crap. Try different ammo like Speer Lawman.

Quack
03-30-2011, 18:32
That would be a good idea before you had a gunsmith work on it because if might void the warranty if Baer has one.

If Wrx04 has an 2004 WRX, he's probably modded it before the warranty was up. I know I did in less than a month of owning mine

Mohawk Grenade
03-30-2011, 18:49
I dont have an SRP but do have a TRS, basically the same minus the wood case and maybe a different safety, don't recall the specifics. The pistols are very tight and need to have some rounds through them. The whole sling shot thing, I do it all the time. I am recalling some of the Baers have a shock buffer in them that inhibits the sling shot, again, this is from memory so no flames if I am mistaken.

Hokie1911
03-30-2011, 18:55
I dont have an SRP but do have a TRS, basically the same minus the wood case and maybe a different safety, don't recall the specifics. The pistols are very tight and need to have some rounds through them. The whole sling shot thing, I do it all the time. I am recalling some of the Baers have a shock buffer in them that inhibits the sling shot, again, this is from memory so no flames if I am mistaken.

His SRP is a commanche.

wrx04
03-30-2011, 19:25
If Wrx04 has an 2004 WRX, he's probably modded it before the warranty was up. I know I did in less than a month of owning mine

I HAD an '04 WRX.....sold it almost a year ago exactly. It was an awesome car.

NFK
03-30-2011, 19:29
Call Les. He will come to the phone and he will make it right. That is my personal experience. And when it runs right there is nothing finer.

wrx04
03-31-2011, 12:19
I just shot another 350 through it today (all reloads) and didnt have a single problem. It still shoots the brass straight back every once in a while. I got used to the sights/trigger and shot very well today. Hopefully it will run smooth from here on out.

GioaJack
03-31-2011, 12:33
Empirical evidence that factory ammunition is the root of all problems... well, that and marriage.


Jack

knedrgr
03-31-2011, 13:09
~$150 and a trip to a smith will fix it for you.

I may go that route if the issues continue....hell, i may do it regardless. I think it was severns that said he's done it many times and its a pretty easy fix.


I have a dremel for that... :rofl:

knedrgr
03-31-2011, 13:10
If Wrx04 has an 2004 WRX, he's probably modded it before the warranty was up. I know I did in less than a month of owning mine

I HAD an '04 WRX.....sold it almost a year ago exactly. It was an awesome car.

:rofl: 03 WRX still since 2003. Warranty...what's that? :whistling: