S&W K-Frame Bolt Spring Issue [Archive] - Glock Talk

PDA

View Full Version : S&W K-Frame Bolt Spring Issue


SuperSleuth
04-01-2011, 18:54
I'm having an issue with the bolt spring for my 2" 64. The bolt spring wasn't holding the bolt in place with the cylinder open; the latch moved back and forth without any tension in it.

Here's a really bad picture of the bolt:

http://i247.photobucket.com/albums/gg151/gotlyrics/2ndBolt.jpg

If you notice on the left, the plunger is barely sticking out of the bolt. The spring is in there. I took the bolt out of my 3" 65 to compare them. Using a paper clip as an improvised depth gauge I found the hole in the 64's bolt (the one with the issue) was about twice as deep as the hole in the 65's bolt (the one that works fine).

When I removed the paper clip from the 64's bolt, a small spring about half the length of the bolt plunger spring came out with it.

I should note this is the second bolt I got for the 64. The original bolt sheared off the cylinder latch mounting post. The original bolt also had a deep spring hole.

I would welcome any help on how to fix this issue. I thought about getting a 3rd bolt, but I don't know how I would go about getting one with a hole of the proper depth. I thought about using two springs in the bolt, but I don't know if that would be an effective fix.

Thanks in advance for an suggestions. I really like this 64 and I'd like to get it back to shooting/carry condition.

garander
04-03-2011, 17:04
seems hard to believe they would drill the hole too deep, but i quess anything's possible. maybe you got ahold of the wrong spring?
just had my 64 apart last weekend and that spring really keeps that pin pushed out firmly. new spring followed by new pin, then a new bolt if need be. good luck