Slide removal after NY1 install [Archive] - Glock Talk

PDA

View Full Version : Slide removal after NY1 install


bigred0383
04-17-2011, 00:00
I think my search-fu is lacking.

I have a quick question that I can't seem to find an answer for.

I just installed the NY1 trigger spring, and as far as I can tell, installed it correctly (matched up the curves, the notch fits in the back, and the cruciform rests on the top of the plastic).

With the regular spring installed, when I pulled the trigger to disassemble the slide would just come right off.

Now I have to pull the trigger again after I have already pulled it once, drawing the cruciform down far enough to get the slide off, as it's new resting position when "decocked" is higher than that of the normal spring.

Did I mess something up, or is this normal?

Also, after firing the trigger, before reset the trigger seems to move forward to the normal firing position, even though it isn't reset. It will reset normally, but to the casual observer, it looks like it already is, until you apply pressure and it isn't there.

Does the new spring really provide that much upward force to make these two changes so apparent over the normal trigger spring?

I am assuming everything is fine as it would seem that the way the old spring works, it holds the trigger back and down, as opposed to the upward force from the new unit.

Thanks in advance!

SuperSleuth
04-17-2011, 00:56
It's normal. I have the NY-1/"-" connector combo in my G23 and it does the same things. Don't worry about it.

bigred0383
04-17-2011, 01:11
Cool, thanks!