Whimpy ejection [Archive] - Glock Talk

PDA

View Full Version : Whimpy ejection


Ferdinandd
09-14-2011, 18:11
I shot trap with my 870 Tactical this evening. By the way, this is excellent training, IMHO - you shoot a lot, are forced to hit small moving targets, swing left, right, up, down, etc.

Anyway, my 870 Tactical, which has been shot about 200 times now, would barely get the empty hulls out of the receiver; one actually didn't clear it. Extraction was fine for the most part, except for one shell (cheap Estate brand), which required two hands on the forend to open the action. Hulls typically landed on the ground about 1-2 feet from me. In comparison, my M500 would chuck them about 5-7 feet.

It seems like ejection from the 870 should be more robust. Assuming that's true, what do I need to do to correct this? Thanks in advance.

aippi
09-14-2011, 18:17
Go to www.aiptactical.com (http://www.aiptactical.com) and read the red link "Install and Cleaning" make a cleaning/polishing rod as on that page and keep your chamber clean.

The main issue is you have to rack the weapon with authority to eject a shell.

Ferdinandd
09-14-2011, 21:38
Thanks for the reply J.D. This isn't my first 870, and it's about the 7th pump that I've owned. This one's ejections seems especially anemic. I'll try it out with some empty hulls tomorrow to determine what role a sitcky chamber might have played. Hoever, my impression was that a single shell was holding the gun in battery.

Buffering
09-14-2011, 23:50
http://misterdiplomat.files.wordpress.com/2008/07/nuns_with_guns_big.jpg

If the nuns don't have problems shooting you shouldn't either. Be more like a nun.

vafish
09-15-2011, 07:09
It may be ammo related if all you were shooting was the estate brand.

Is try some remington, federal, and winchester to see if the problem is consistent.

2-8 Marine
09-15-2011, 07:37
OOOPS! Wrong thread, I though this was about erectile disfunction. :whistling: