Mini 14 Loading Problem [Archive] - Glock Talk

PDA

View Full Version : Mini 14 Loading Problem


Linux3
11-07-2011, 18:12
I've had my MIni 14 for about 18 months and it's been just great, until last week.
After the first few rounds out of a mag it would either try to load 2 rounds at once or load a ruound but nothing would happen when I pulled the trigger.

I have tried 2 different 30 round Ruger mags, 2 20 rounders and a couple of 10 round. All do the same.

Whe it chambers a round but doesn't fire I work the bolt, eject a good round (no strikes on the primer) and it will then fire. Reload that round and it fires.

Other times the bolt jams because it trying to feed 2 rounds or 1 get hung up.

As I said, this just started happening all of a sudden.

BTW, I use nothing but factory ammo.

Ethereal Killer
11-07-2011, 19:16
sounds like it might be short stroking or not cycling properly for some other reason. this could be any or several of the following:

-bad feed lips/mags. some 30 rounders had problems. but factory Ruger brand 20's are almost bombproof.
-debris in the bolt path. clean, lube, check for damage on all parts that contact the bolt
-gas system clogged or blocked
-trigger group could be faulty. once again, clean lube and check for damage and excessive wear and blockages of movement pathways.

thats about everything that can go wrong with a Mini. you should seriously consider sending it in to ruger. they can go thru it and will replace anything that is out of spec. if it's an older model (pre 580-xxxx) you might consider telling them it's not very accurate (if it is bad) and they will go thru and tighten a few things up for you.

I would check on if the work will be covered under warranty and remove any aftermarket parts you want. you may also take the opportunity to ask for a few spare parts to be fitted while it's in.

HTH

michael e
11-07-2011, 19:28
Only issues I ever had with my Mini 14 or 30 was from aftermarket mags not feeding right. But seems you have tired several and having same issue. Are they factory mags ?

Linux3
11-07-2011, 21:22
Only issues I ever had with my Mini 14 or 30 was from aftermarket mags not feeding right. But seems you have tired several and having same issue. Are they factory mags ?
Yes they are factory mags.

I have cleaned the rifle twice. I thought maybe I put something together wrong that's why the second time but it's right.

MinervaDoe
11-08-2011, 15:30
BTW, I use nothing but factory ammo.
Describe your ammunition.
What brand is it?
Is it choking on more than one brand of factory ammunition?

Only issues I ever had with my Mini 14 or 30 was from aftermarket mags not feeding right.+1
I've had a Mini 14 since 1981.