issue with mini draco dust cover [Archive] - Glock Talk

PDA

View Full Version : issue with mini draco dust cover


The_Gun_Guru
05-24-2012, 09:51
It does not lock in at the front. The 1 from my full size WASR10 Fits just fine. Is anyone else having the same issue?

Thanks,

TGG

rtl
05-24-2012, 11:19
Did it fit right when you got it? I found that it was very difficult to get back on correcty because of the spacer at the back....sometimes I had to use a rubber mallet to help.

LSUAdman
05-25-2012, 07:49
I dont have the mini, but the full sized Draco and noticed the same thing. It fit poorly when I first got it -needed a hammer to get it on, and even then it would "bulge" over the sides of the receiver. I filed down some of the contact points and that helped, but it still never fits 100%.

So far it hasnt proved to be a problem with function - but I am considering getting another top cover just to replace it. If you decide to go that route, let me know if that fixes the problem.

The_Gun_Guru
05-25-2012, 08:03
Did it fit right when you got it? I found that it was very difficult to get back on correcty because of the spacer at the back....sometimes I had to use a rubber mallet to help.

I have a rubber mallet and will give it a try, thanks.


I dont have the mini, but the full sized Draco and noticed the same thing. It fit poorly when I first got it -needed a hammer to get it on, and even then it would "bulge" over the sides of the receiver. I filed down some of the contact points and that helped, but it still never fits 100%.

So far it hasnt proved to be a problem with function - but I am considering getting another top cover just to replace it. If you decide to go that route, let me know if that fixes the problem.

I am presently on the hunt for a Romanian dust cover and will let you know how, and if, it works.

Thanks all,

TGG

The_Gun_Guru
05-25-2012, 08:57
Did it fit right when you got it? I found that it was very difficult to get back on correcty because of the spacer at the back....sometimes I had to use a rubber mallet to help.

Hey! IT WORKED!!!!:banana:

http://i203.photobucket.com/albums/aa310/gunguru364/2012-05-25_10-24-42_175.jpg

It snapped right in and is back to normal:thumbsup:

Thanks for the help!