Ruger MarkII [Archive] - Glock Talk

PDA

View Full Version : Ruger MarkII


jcountry
06-09-2012, 13:44
I am really scratching my head trying to figure out what is up with my Mark II.

I have had a couple of slam fires, but what is more common are misfeeds (the round gets stuck halfway in the chamber and is bent) and sometimes it will feed, but the hammer has already fallen and the trigger won't pull.

Anyone seen these things from Mark II? I am shooting good ammo-always CCI minimags (seem to do best,) but am still getting a malfunction about every 25 or 30 rounds. Seems to be one of the above-randomly.

JaPes
06-09-2012, 15:24
Maybe it's time to replace some of the common wear items? Springs perhaps?

Cwlongshot
06-09-2012, 16:02
Sounds to me like someone was "inside"...

The trigger return and feed lips on the mag come to mind...

The slam fires could be a very dirty slide...

I would first disassemble, then completely and thoroughly clean the gun.

Then check the feed lips on the mag, could have been dropped or "tuned" but a novice..

On the trigger is it stock? or has someone added a over travel screw? The screw could be too long. If not again a overly dirty gun could cause the problems...

Good luck,
CW

FL Airedale
06-09-2012, 16:26
I was having feeding problems with my MK II yesterday. After some testing I discovered it was only with one aftermarket magazine. I didn't spend too much time trying to figure out what was wrong with it. I just dumped it in the trash and ordered two new Ruger made mags for it.

jcountry
06-09-2012, 21:58
Good ideas.

I do have an aftermarket mag. I will check that as well as look for that overtravel screw-

-thx

RWBlue
06-09-2012, 22:43
First, clean it. While doing this look at all the parts. Something may be broken.
Second, buy a new factory mag.

Take it out and see if there are any issues. If you make it to this point and are still having issues......post again.

BTW, try some other ammo. Some guns just don't like some ammo.

jhertzler
06-27-2012, 19:34
I am really scratching my head trying to figure out what is up with my Mark II.

I have had a couple of slam fires, but what is more common are misfeeds (the round gets stuck halfway in the chamber and is bent) and sometimes it will feed, but the hammer has already fallen and the trigger won't pull.

Anyone seen these things from Mark II? I am shooting good ammo-always CCI minimags (seem to do best,) but am still getting a malfunction about every 25 or 30 rounds. Seems to be one of the above-randomly.

I have had some of this with my MKII. I have factory magazines only, but I found that I needed to make some adjustments with the feed lips. I used needle nose pliers and bent them a bit to get the shell coming out at the right angle for a proper feed. Seems to have fixed it. Joe