Commander being persnickety! [Archive] - Glock Talk

PDA

View Full Version : Commander being persnickety!


G26AZ
09-14-2012, 15:04
Went to the range today with my Colt (LW) Commander. It has been plated with NP3+ by Robar, and also received the "reliability" package at the same time. On the two previous trips since being plated, everything worked fine.

Today, however, I started to notice problems. I was using McCormick SS 8 rnd magazines (the kind with rubber bumpers on the base), and Winchester 230 gr PDX1 ammo. I noticed that the slide was not locking back after the last round. I thought this was strange but continued to shoot. Then it started to jam (not feeding all the way up into the chamber) and I noticed that the slide stop was working its way out the left side of the gun!

This is my 1st 1911, and am still learning the ins and outs of proper care and feeding of the 1911, so I am wondering where to start in looking for the reason for this?

Any ideas or suggestions would be appreciated. If it something mechanical, I plan on taking it back to Robar's and asking them to fix it, but would like to have an idea of what is wrong before I do that.

Thank you for your help in advance!
John

fnfalman
09-14-2012, 16:11
My guess is the "reliability package" is the problem.

samuse
09-14-2012, 17:28
Check the plunger spring and plungers, check to see if the plunger tube is loose.

cowboywannabe
09-14-2012, 17:35
i used to have junk i mean persnickety guns, then i wised up and got rid of them....

Troubled Gecko
09-14-2012, 17:58
Check the plunger spring and plungers, check to see if the plunger tube is loose.

Agreed, also check that the rnd isn't bumping the slide stop.

bac1023
09-14-2012, 19:32
It could certainly be the plunger tube.

kat1950
09-14-2012, 19:47
Agreed, also check that the rnd isn't bumping the slide stop.

Also check if there is any copper fouling on stop, if plunger is alright try different mags and get a new Colt slide stop and try that.

Robar has done a couple of mine, have had no problems with, If I was you I would definitely give robar a shout.

Short Cut
09-14-2012, 21:48
Were those mags working for you before? I've found some 1911s seem to work with any mags any ammo, but others are more selective on the mags and or ammo. Because I have lots of mags from different makers that's the first thing I'd try with the problem you described.

G26AZ
09-15-2012, 22:25
i used to have junk i mean persnickety guns, then i wised up and got rid of them....


Are Colts now considered to be "junk" guns?


Thanks for the suggestions. I haven't had a chance to disassemble it since we got back from the range, but will definitely check out the plunger and tube, etc.

Thank you!

faawrenchbndr
09-16-2012, 02:47
Nope, but Taurus on the other hand..............

pistolwrench
09-16-2012, 07:10
Check to see if the internal lobe of the slide stop has broken off.
Not uncommon with Colt slide stops.

G26AZ
09-17-2012, 21:17
I took it apart, cleaned it, inspected all the suggested parts and areas, and it all seems to be working fine now - no more coming apart or mis-feeds,etc.

All I can figure is that I did not get the slide stop all the way in last time I cleaned it, and it worked its way out while shooting last time. If that was the case, then I can guarantee that it will never happen again. I will double and triple check that the slide stop is all the way in every time it is taken apart and re-assembled.

Thanks again for all the help and suggestions!