Ghost rocket trigger reset issues. [Archive] - Glock Talk

PDA

View Full Version : Ghost rocket trigger reset issues.


rgomez1787
11-18-2012, 09:19
Hi everyone. Ive been a member here for a while but this is my first post. I'd like to start off by saying I google searched and searched on here and couldn't find anyone having the same issues as me. I bought a ghost rocket trigger for my glock 34. I took my time shaving the tct bar little by little. Also gave it a slight angle like dave spaulding does. The trigger breaks and resets with dry fire but once I took it to the range and fired it for the first time the trigger would not reset. I had to pull the slide slightly back to reset the trigger just to send the next round down range. I brought my old trigger bar to the range as a just in case and im glad i did. I swapped trigger connector to the factory glock connector while at the range and it worked perfect. Did I shave the tct bar too much or not enough?

Ammo9000
11-18-2012, 11:54
Most likely you didn't file it enough. I had a a ghost rocket in all my Glocks for about a month. I don't use them anymore because i had the same problem. Every once and a while the trigger wouldn't reset. Wouldn't want that to happen when i really needed it. All stock for me except for sights.

English
11-18-2012, 11:58
It is nothing to do with the tct. If you had not shortened it enough, you would not be able to pull the trigger far enough to release the striker/firing pin. If you had shortened it too much, there would just be too much over travel. What is happenig is that the cruciform is not popping up quickly enough to catch the striker lug when the slide is recoiling and returning under recoil. When you pull the slide back manually there is enough time.

This can be happening for only one of two reasons. Either the trigger spring is not pulling back and up strongly enough or there is more drag on the trigger bar than there should be. Since it works when you replace the original connector, it can hardly be that the spring is too weak. Therefore, there is too much drag. That is a tricky one!

When the slide moves back, manually or under recoil, the ramp on the underside of the slide pushes the half round ear on the connector inwards. As the slide comes forward again, this process is reversed and the connector springs out again. In its inwards position, the birds head part of the trigger bar cannot be under the small ramp at the top of the connector. If you have just pulled the trigger, the trigger bar then flicks upwards because it slides of the side of the ramp and picks up the lug before the lug is carried forwards past it as the slide returns. This is when your failure occurs. Something is slowing the upward movement of the trigger bar. The ramp on the underside of the slide is not shallow relative to the width of the ramp on the end of the connector but that is very shallow. It is not even as wide as the thickness of the trigger bar that it pushes downwards as the trigger is pulled. That suggests that this is a marginal size as, oterwise, Glock would make it at least as wide as the thickness of the other side of the bearing surface.

If that ramp is too wide, it could be narrow enough to slide off the birds head to the side (especially if the edge of the ramp is a little rounded as the polishing process will have made it), but wide enough to be pressing on the side of the bird's head part of the trigger bar as the trigger bar is being pulled upwards by the trigger spring. That could be, and I think it is, the source of the drag that is slowing its rise.

So what should you do? You could, of course, just grind it down until it works, but one of the great virtues of the Ghost connectors is their really excellent level of polish. By grinding it down you are likely to get a burr on its edge and that will cause increased and erratic friction as you pull the trigger. The best thing to do is to send it back to Ghost with and explanatory letter. They are excellent about replacing things. Feel free to copy them with this post.

I hope that this explanaion is correct and cannot, for the time being, see that it can be anything else. Please let us know how you get on.

Best of luck,

English

PS I can think of another reason. If you have not shortened the tct quite enough, and especially as you have used the Dave Spaulding angle, the tct might be dragging on the cross bar of the cruciform with the same problem as above. So polish it first and polish the cross bar. If that des not do it, take just a little off it and polish again. If that does not work, send it back as previously suggested.

English