Crimson Trace on my 19 [Archive] - Glock Talk

PDA

View Full Version : Crimson Trace on my 19


Treefrog23
12-14-2012, 11:37
I have a CT laser on my SR22, and a LG412 on my LC9. I couldn't be more pleased with the Laser guard on the LC9, so I bought one for my Gen 3 Glock 19.

When you bring the pistol up on the LC9 the sight activates perfectly. The one on my 19 requires a great deal of pressure to activate, to the point my hand shakes. I sent it back, it was retuned (no record of what they did), but it is still very hard to activate. Is anyone else having this problem?
TF
Knoxville, TN

Rich22
12-14-2012, 15:20
I have a CT laser on my SR22, and a LG412 on my LC9. I couldn't be more pleased with the Laser guard on the LC9, so I bought one for my Gen 3 Glock 19.

When you bring the pistol up on the LC9 the sight activates perfectly. The one on my 19 requires a great deal of pressure to activate, to the point my hand shakes. I sent it back, it was retuned (no record of what they did), but it is still very hard to activate. Is anyone else having this problem?
TF
Knoxville, TN

I have two of them, LG436 to be exact, it does not require any more pressure than normal for me. 1 turns on practically if you look at it hard or in a stiff breeze.

fishflash
01-06-2013, 13:24
I have them on my Gen 4 19 and have no problems. You may have gotten a bad switch. I have them on other handguns as well and function easily. Have you contacted the mfg and explained the situation. They're very easy to talk to and the CT is such a good value. Good luck