G23 with TLR-1 issues [Archive] - Glock Talk

PDA

View Full Version : G23 with TLR-1 issues


Socom Elite
01-29-2013, 21:54
I know there are already threads on this, but has anyone found a solution? I have a gen 3 and my mags have a 2 next to the Glock logo on the back and a 9 on the follower so I think they are the new ones, but I am having a lot of failure to feed malfunctions.

Usually in these threads I see all these posts about how their gun works. I want to hear from the people that had problems and what if any was the solution.

I had the screw tight i guess, but only hand tight. When I got home after the range today and researched the issue I loosened it a turn so its loose, but won't come off. Ill take it to the range again Friday and put some more ammo through it and see how it does.

I really want to be able to run this light on my gun, but I can't sacrifice reliability for it.

Socom Elite
02-02-2013, 17:29
Anyone?

bennie1986
02-02-2013, 17:43
Does the slide fail to fully engage the next round or does the round get jammed on something?

bennie1986
02-02-2013, 17:47
Also what kind of ammo are you using and are there any mods to the gun and specifically the guide rod spring.

Socom Elite
02-02-2013, 18:29
Also what kind of ammo are you using and are there any mods to the gun and specifically the guide rod spring.

The gun is completely stock. I used. Blazer brass, Tula, and federal.i think the majority of failure to feeds were from blazer and tula. Yes I know they're cheap ammo, but I've never had a problem with it in any other firearm. I wanted to go shoot yesterday but couldn't make it out. Maybe next weekend.

The failures were failure to feed btw.

I have read plenty of other stories about this happening to others. Hopefully someone found a solution.

I already emailed Glock and are awaiting their response