LFS revisited [Archive] - Glock Talk

PDA

View Full Version : LFS revisited


lomfs24
06-28-2004, 22:35
Well, my LFS (Linux From Scratch) is coming along quite nicely considering the amount of time I have dedicated to it. It will boot (only two kernel compiles to get that one right) I have several apps working (though maybe not correctly) I can get a pcmcia card to come up and turn on, I can get a wireless card to connect to an AP and I can get it to pull an IP address via DHCP. I even have Kismet working on it. So far so good.

Now I want to just let it run for a while. I want to see if it will remain stable after some time. Basically turn in on, throw it in a corner and forget about it for a while. But I want to access it to see how things are running, uptimes etc... so I installed ssh. I got ssh-2.3.9.1.tar.gz from freshmeat. I untarred, compiled and installed. So far so good. I can ssh out to another machine but when I try to ssh in I get a connection refused warning and no go on the ssh session. What am I missing?

Thanks.
RA

aspartz
06-28-2004, 23:02
do you have the ssh daemon running? I'm stuck in winblows right now, so I cannot check if the server is in the same package as the client side.

ARS

lomfs24
06-28-2004, 23:05
I got it figured out. To answer your question, NO, sshd was not running(notice, past tense) It is running now. The reason I had over looked it was that ssh was located in /usr/local/bin and sshd was located in /usr/local/sbin

I got it figured out now. Thanks again.

edit-- I am used to nice slick distros like Suse and Redhat that automaticall start all those neat features for you at boot time. With LFS you have to start all them manually. I have not taken the time to make them turn on automatically yet. Or really, I have not taken the time to figure out how to make them start at boot time. I would like to get dhcpd, sshd to start automatically, I would also like to get eth0 to come up by itself. Oh well, future projects.

aspartz
06-28-2004, 23:59
Even as type, I am bit-torrenting LFS 5.1.1. I nuked my system (my fault) building 5.0, but if I ever find any spare time, I'm gonna get this one to work.

Either that, or D/L all of the SRPMs for FC2 and rpmbuild for the rest of my natural life. lol

ARS

lomfs24
07-25-2004, 23:23
Well, my LFS box has been up and running since this post was started.

-bash-2.05b$ uptime
23:10:54 up 26 days, 22:41, 2 users, load average: 0.00, 0.00, 0.00

It is not an unbelievable uptime but I think it is pretty good for my first LFS build and on a machine that winblows wouldn't stay up on for more than 12 hours without crashing.

Now it is time to take it down and start building more apps for it. Next is an Xserver