Network (LAN) help w/ XP [Archive] - Glock Talk

PDA

View Full Version : Network (LAN) help w/ XP


Willard
07-22-2004, 16:06
Guys,

I am trying to get two computers at work to "talk" with one another.

I have DSL, with a router. Both computers can access the Internet with no problem.

One computer has XP Home, the other has XP Pro.

I have checked IP settings, and "Pinged" the computers, which worked fine.

I have run the "Windows Networking Wizard" a couple of times, on both computers.

I have triple-checked that both computers have the same workgroup name.

In "My Network Places", I get an error message that says "Johnsonchiro is not accessible. You might not have permission to use this network resource..."

Any ideas?




Bueller?

Bueller?

HerrGlock
07-22-2004, 16:57
Check out the built in firewall of XP on both machines.
Make sure your username is the same on both.
Make sure each has permission to talk to the other.
See if you can see the other one in Network Neighbourhood via the explorer.

DanH

chevrofreak
07-22-2004, 16:59
you can also use IP addresses, such as \\192.168.0.1

Willard
07-22-2004, 17:57
Originally posted by HerrGlock
Check out the built in firewall of XP on both machines.
Make sure your username is the same on both.
Make sure each has permission to talk to the other.
See if you can see the other one in Network Neighbourhood via the explorer.

DanH


1) Uh, check the firewall for _what_, exactly? I _have_ firewalls - what do I do with them?

2) Um, my user names have to be the same? They aren't...

3) The error message states that they don't have permission - how do I change that?

4) On one computer, I can see the other in Network Neighbourhood, but I can't "explore" it. The other computer can't see the first one in NN.

I really appreciate the help, guys!

Willard
07-22-2004, 17:59
Originally posted by chevrofreak
you can also use IP addresses, such as \\192.168.0.1

Um, not sure what you mean. I checked the IPs, and "pinged" from a command prompt. That worked fine. Are you suggesting that I manually set the IPs for WinXP?

chevrofreak
07-22-2004, 18:40
I mean as far as accessing the shares on the other computer. From explorer, or the run line you can use \\ and the computers IP of which you are wishing to browse. You can also do \\ and the computers name, but often the DNS for this doesnt work right.

\\Johnsonchiro

SamBuca
07-22-2004, 18:41
Unless you're running service pack 2, disable the built in firewall or else file sharing won't work properly. You'll also need to remove any other software like ZoneAlarm or Norton Internet Security.

HerrGlock
07-22-2004, 19:01
Originally posted by Willard
1) Uh, check the firewall for _what_, exactly? I _have_ firewalls - what do I do with them?


You have firewalls built into XP, it's in the security settings somewhere.


2) Um, my user names have to be the same? They aren't...


That'll make life much easier.


3) The error message states that they don't have permission - how do I change that?

On the box with the share, go to SHARE by right clicking on the drive and set it to no password, no restrictions.


4) On one computer, I can see the other in Network Neighbourhood, but I can't "explore" it. The other computer can't see the first one in NN.

I really appreciate the help, guys!

See above.

DanH

Willard
07-22-2004, 22:16
Well, yes, I do know what a firewall is - but HOW do I safely turn it and antivirus stuff OFF safely? Does the router stop EVERYTHING that tries to come in on the DSL?



OK, I'll try the "same user name" thing. Makes sense, can't hurt.



And, I did enable sharing - I just neglected to mention it.



Uh, so if I install SP2, that'll make this easier? I updated WinXP today (on both machines). I'll check the history to see if SP2 was included.


I'll try the runline trick, too.



Guys, I really appreciate the help. I'm not a computer-dunce (really, I'm NOT!), but this networking thing is a little new to me, and the various "Windows documentation" (oxymoron) isn't helpful in the least.

Thanks again. I'll work on this some more tomorrow, and let you know...

Blazen
07-23-2004, 05:56
Well, yes, I do know what a firewall is - but HOW do I safely turn it and antivirus stuff OFF safely? Does the router stop EVERYTHING that tries to come in on the DSL?

If you ran the network wizard, the XP built-in firewall is enabled. You may want to disable it, as your router should block everything from coming in. Start, settings, network connections, open up your lan connection, click on the advance tab and uncheck protect my computer. Never turn off your AV; unless you are installing new software and most of the time you don't have to do that.

You don't need to login to both computers with the same account and password to talk to each other (ie login as bob on both boxes). But you need to make sure the same username is added to each computer and those usernames have the same password. They also need to be in the same work group.

For example:

Computer 1
your account passsword xxxx


Computer 2
your account password xxxx
some other account password xxxx

So if you are logged into computer 1, you can access computer 2 by either My Computer, a UNC call (\\computer 2). Now if you want computer 2 to access computer 1, then you need to login as your same account that you use on computer 1. If the "some other account" is logged into computer 2 and they try to access computer 1, it won't work because they are not setup on computer 1 (no username). But if you add the "some other account" to computer 1, then when they are logged into computer 2, they can access comptuer 1.

Also depending on what your doing, you may need to make the accounts part of the local admin group.

SP2 for XP is still in Beta, so you don't have it yet, but in a month, you might.

If you have a software firewall, then you may need to allow your "internal" network to talk to each other (Zone Alarm, Blackice, Norton, Mcafee, etc..).

;c

fatlander
07-23-2004, 07:16
There is no need for the two computers to have the same username,

Try accessing it via their ip adresses:

ex: \\192.168.0.1\ in the adress bar of the explorer

0100010
07-23-2004, 07:32
Yes, you will need the same usernames/passwords logged in on both boxes for the sharing to work. XP Home only has the option to use simple file sharing. That means it will only allow guest account access or the current credentials of the user logged in other remote box, os you want to have the excat same username and passwords logged in on each box, and have that user setup with proper permissions on the shared folders.

If you had XP Pro on both boxes, you could setup the shares and be logged in as who ever you wanted on either box, whe nyou try to access the shared folder, you would get a login prompt.

Willard
07-27-2004, 13:32
Originally posted by fatlander
There is no need for the two computers to have the same username,

Try accessing it via their ip adresses:

ex: \\192.168.0.1\ in the adress bar of the explorer


Well, I'm posting a follow-up.

Accessing via IP addresses worked GREAT! Since doing that, I can map the HDD over the network, and setup a ntework printer. Thanks!

fatlander
07-27-2004, 14:44
here's another tip,
locate the "\windows\system32\drivers\etc\hosts" file and add the nameof the computer and its ip separated by spaces, now every time you put the computers name iot knows which ip to search/