para p16 slide won't open with mecgar mags [Archive] - Glock Talk

PDA

View Full Version : para p16 slide won't open with mecgar mags


vergeman10in
10-20-2004, 01:38
Mga sir,

The slide of my Para P16 doesn't open after the last round has been fired when I use mecgar magazines.

jundeleon
10-20-2004, 02:55
I had the same problem with my mecgar mags for P14.
Many recommended that the mecgar mag spring be replaced with wolff +10% springs.

ogiebb
10-20-2004, 07:35
a lot of factors mag spring,followers,or slide stop..check them out..;)

vergeman10in
10-20-2004, 21:24
thanks guys

Longbow
10-20-2004, 21:38
Check/change the follower and spring first. I only use factory nickel or STI built mags for my P16. The Mecgars are almost always bad, from my experience.

Allegra
10-21-2004, 00:46
Originally posted by vergeman10in
Mga sir,

The slide of my Para P16 doesn't open after the last round has been fired when I use mecgar magazines.


Di naman importante yun pre
Anyways madali lang yun, di lang tumatama yung slide stop sa follower kaya ayaw mag engage
tANGGALIN MO SLIDE AND isaksak mo yung mag and you will see if there is a gap between them
Paayos mo kay metrillo etc if it bothers you too much

vergeman10in
10-21-2004, 03:28
Are the arredondo followers any good?

ogiebb
10-21-2004, 05:40
Originally posted by vergeman10in
Are the arredondo followers any good?


the teflon one's are good (white) the red i dont really care for;) ;)

Longbow
10-21-2004, 12:32
Originally posted by vergeman10in
Are the arredondo followers any good?
I don't know what color it comes over there, but the blue ones I've tried are junks. They mis-align (sideways) when the mag is full and get stuck in the tube.