Oil in air cleaner problem [Archive] - Glock Talk

PDA

View Full Version : Oil in air cleaner problem


manonmars
10-30-2005, 11:04
Someone is giving me a ford or mercury car.

About a 1992 +/-.

Body/interior good shape..it's been sitting for 1.5 years. He said it was running fine when parked BUT......

It started smoking, and he found about 1/4 inch of oil in the air cleaner.

Is this a PCV/emission type problem, or is it more serious.

It is a 6 cyl.

Sorry about the lack of facts...but I just saw the car briefly yesterday, and am headed over to take a closer look today.

Thanks for your help and ideas..

Mighty HD
10-30-2005, 11:37
It sounds like a PCV problem to me. I'd make sure the lines are clear and see how that works. It may have a serious blowby problem....

manonmars
10-30-2005, 16:59
Thanks for the reply. That is my thought too, but ??????????????

I cranked it over today, couldn't get it started even with starting fluid.

Pulled plugs....YUCK! about 3" gap and 2 were brown, 2 were black.......

Next step......clean plugs & try again.....

I jumped the car THROUGH the original battery, which is DEAD!.

I was told this will decrease spark to plugs...it fired on about 1-2 plugs but would not start......

It's a 4 cyl, auto with all electric windows/seat/locks etc, so it is a car worth saving, I think!

Any oother thoughts, or am I on the right path?

THANKS.

Mighty HD
10-30-2005, 17:06
Well if the plugs are that bad...

I would get new plugs, new wires for SURE, a distributor cap & rotor (if it has it..I think it does you didnt mention a model/make/year/engine) Check to see if it has fire, if not move up to the coil, and if it still does not work maybe a distributor.

I would for sure do the plugs wires, cap & rotor.

It may not fire up due to a clogged fuel filter and bad fuel. If the above dosent work, drop the tank, clean it out and put fresh fuel in it--about 3 gallons, and a new sock on the fuel pump.

keep us updated.

streeter69
10-31-2005, 10:45
Originally posted by manonmars
Thanks for the reply. That is my thought too, but ??????????????


Pulled plugs....YUCK! about 3" gap and 2 were brown, 2 were black.......


Any oother thoughts, or am I on the right path?

THANKS.

Any of the plugs look like ash fouled but dark like oil??

http://www.centuryperformance.com/spark2.asp

Mighty HD
11-02-2005, 06:19
Whatever happened with ol' clampey?

KinderGlocken
11-02-2005, 06:48
too much oil? check dip stick

NailShooter
11-13-2005, 18:27
Assuming it's not over filled w/ oil, then it sounds like the rings are gone. Let it run with the oil fill cap removed, if it's puffin' smoke out of there, the rings are likely worn out. Check for operational PCV valve also.

NS

GLOCK22SHOOTER
11-26-2005, 10:13
Sounds like clogged jets or clogged fuel injectors

mkoricic
12-17-2005, 01:37
I think u messed up when u tryed to clean 3" gaped plugs and 2 black/2 brown. imo

mkoricic
12-17-2005, 01:39
Also is DOES NOT matter what the battery is/was is you jump the car it would draw off the other car and turn over.

45acp4me
12-18-2005, 09:17
If it sat for a year and a half it's going to cost you more in time and parts than the car is worth. Tell them thanks but no thanks.