Electircal problems [Archive] - Glock Talk

PDA

View Full Version : Electircal problems


crater
01-14-2006, 08:34
O.K. You guy's, I need your help one more time. You GT's have saved me money before with your help, and I'm asking for some more advice.

I have a 97 Malibu. Yesterday after starting up and driving about 25 yards, I heard the chime go off and my battery light was on. It stayed on until I turned the engine off in my work parking lot. After work, the car started fine with no light on, but once again, about 20 yards of driving it came back on. This morning, I had to run some fast errands, and the car started fine, no light, but then again the chime, and the light came back on. After awhile, the light when out, but then it came back on. After about 5 minutes of driving, my ABS light came on. I got to where I needed to go, and was
not sure if I should shut the engine off, but I did.

Got back in, the car started fine with no battery or AMS lights on, but it all happened again. First the battery light, on then off, then back on and then the ABS light came on.

When it gets a little warmer out today, I plan to check the belts and other things, such as kick the tires.:)

Another thing I might mention, but no sure it's related, is that recently, prior to all this happening, my switch for my heater, would switch from fresh air return, to car air return, all by itself.

Anybody have any ideas of whats wrong, or is my car haunted?;f

Would appreciate any ideas or suggestions...

Thanks