Rough idle/Air intake gaskets - Mazda 2001 Tribute [Archive] - Glock Talk

PDA

View Full Version : Rough idle/Air intake gaskets - Mazda 2001 Tribute


BarkinDog
11-01-2006, 10:32
I took my wife's 2001 Mazda Tribute in for service because when cold starting the engine idles rough and stalls. Once it's run for a couple of minutes it's okay. They said it needed upper and lower air intake gaskets due to a (vacuum?) leak. Including the $90 diagnostic fee, 80 +30 for gasket kits, the total will be $515 +tax.
I haven't had them do the work yet since they had to order the gasket kit.
A day after they looked at it the check engine light came on, I used my scanner and it came up with a 1131 and 1151 error- Heated O2 sensor - lean (I think they both said left bank, #1 , I don't have the error code book here at work).

Does the gaskets replacement they are suggesting sound like it could be the actual cause and resolution? I don't want to think they are charging me over $500 and will just replace a sensor or two or replace the gaskets if they are needed.

Thanks in advanced for any help with this. I'm lost when it comes to anything on cars made after the early 70's, too many hoses and sensors.

southernshooter
11-03-2006, 04:38
Could you spray something around the suspected leak area while the engine is running to see if it changes the idle, so you would know if it is sucking air? After they get your $515 and it is no better then they will probably say "Yeah, it needs a new 02 sensor also, that will be another $515.

Clydeglide
11-03-2006, 10:11
Originally posted by southernshooter
Could you spray something around the suspected leak area while the engine is running to see if it changes the idle, so you would know if it is sucking air? After they get your $515 and it is no better then they will probably say "Yeah, it needs a new 02 sensor also, that will be another $515.

Check the gaskets as suggested. That will answer your question.

Don't assume it has only a bad sensor. I believe it senses the lean condition due to the gaskets and is responding.

It MAY also need a sensor but if the gaskets are leaking you would have to replace the gaskets first.

To just replace a sensor without repairing the upstream problem is foolish.

:cool: