Both DVD Drives locking up [Archive] - Glock Talk

PDA

View Full Version : Both DVD Drives locking up


Philipp2
05-19-2007, 21:15
I built up a fairly high-end computer for my grandson last year with MS Windows XP Media Edition, 4Gb Ram, etc. Everything has been working fine, but last night I got a call saying that the computer locks up (freezes)when a DVD is inserted. If you leave the disk in and restart the computer, it will work OK. I was going to try plugging the IDE cable into the second IDE plug, but there is only the one on the MB. We tried unplugging and replugging, no help. We will try replacing the round IDE cable with the stock ribbon just to see if that might help. Worst case, I might replace one of the drives with a SATA interface drive ~ $35.00 Or get a PCI to IDE card.
Any ideas as to what might be causing this? Bad controller on the MB ?? :sad:

Blitzer
05-19-2007, 23:13
Would you get on the phone and expect your auto mechanic to fix a major problem? :shocked:

When asking tech questions we need more details of what went into the computer, like the motherboard's brand, model and revision, the BIOS brand and revision , which CPU, make and model of the drives, etc.

What was the last software installed and when? Did the problems start after a software install or upgrade? Details, we need more details. :thumbsup: ;)

Just for worst a case scenario if the onboard Drive controller went bad replacing it with a slot board would only prolong the agony of the motherboards slow death. The motherboard would need replaced. :sad:

Washington,D.C.
05-20-2007, 09:43
It could one of the drives is bad but more likely it's software. The latest versions of Windows Media Player have some CD/DVD software. Most CD/DVD software requires that it be the only CD/DVD software in the PC. If another program that was added also has CD/DVD software it can really confuse things. Are you talking about a movie DVD? Some movie DVD's add software to the PC on their own. Sony movie DVD's had a problem with this that they had to remove on newer DVD's. Some movie DVD's have "enhanced" playback software that installs in the PC when the DVD is played. It's best to keep movie DVD's out of the PC and watch them with a DVD player on the TV.

Philipp2
05-20-2007, 10:16
Computer build-up:

Antec Performance I P180 Silver
PC Power & Cooling Silencer 750 EPS12V EPS12V 750W Power Supply
GIGABYTE GA-965P-DQ6 Socket T (LGA 775)-
Intel Core 2 Duo E6700 Conroe 2.66GHz 4M sharing L2 Cache LGA 775 Processor
Kingston HyperX 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)
eVGA 640-P2-N821-AR GeForce 8800GTS 640MB 320-bit GDDR3 PCI Express x16 HDCP
Western Digital Caviar SE16 WD2500KS 250GB 7200 RPM 16MB Cache SATA 3.0Gb/s Hard Drive
LITE-ON Black 16X DVD+R 8X DVD+RW 8X DVD+R DL 16X DVD-R 6X DVD-RW 16X DVD-ROM 48X CD-R 24X CD-RW 48X CD-ROM 2M Cache ATAPI/E-IDE 16X DVD Burner
LG Black 18X DVD+R 8X DVD+RW 8X DVD+R 2M Cache IDE Super-Multi DVD Burner
SILVERSTONE SST-FP52-B Black Aluminum Multifunction Panel
VANTEC Clear 18" ATA 66/100/133 IDE Round Cable, 3-Connector
Microsoft Windows XP Media Center Edition 2005 w/SP2B

All above items from NewEgg.

I have not personally viewed the lock-ups, but I believe that they occur during the initial read of any DVD.

Once upon a time, long, long ago, I had a Dell that lost the parallel and serial ports on the motherboard. I installed a PCI card with the missing ports and all was well for several years, since retired.

doktarZues
05-20-2007, 17:58
Try the drives 1 at a time (both set as master), and see if 1 locks up and 1 doesn't, if so, replace that drive, easy fix. (Make sure you use the new or a known good ide cable).

If that doesn't fix it, it's likely a MB problem. Very unlikely it is a software problem. If you can't identify/replace a faulty DVD drive, I would go with an IDE PCI card (rather then replacing the MB), they're very cheap, and a good bet to fix it. -dok

doktarZues
05-20-2007, 18:03
Check what's autorunning.. Maybe a software that's been corrupted is causing the lockup? Have you tried holding the (left) shift key for 15 seconds while the drive spins up?

There's an option you can check to "always do this when this media is inserted", and if the program is locking up it could certainly cause that.. I've googled and found the fix before to get rid of the automatic selection for autorunning. . -dok

Philipp2
05-20-2007, 18:16
What do you think about replacing with a SATA DVD Drive if the normal "fixes" don't work?

NewEgg has a good looking Sony for around $32. The MB has several unused SATA slots left.

kimigirl
05-20-2007, 19:11
Are you sure there is only one IDE slot? I've never seen a computer with just one, that doesn't make sense.
Anyhoo, my first impression is a possible driver issue, or a resource conflict. Check to make sure that nothing else is trying to use the same IRQ that the IDE controller is using, I believe its 14 and 15 for primary and secondary IDE respectively. Other than that, the drive may be going bad. An SATA drive would work ok, one of my computers is completely SATA but I really haven't noticed a great difference in speed.

Philipp2
05-20-2007, 20:04
That's what my grandson reported and I looked it up on NewEgg's site
Item # N82E16813128323

The specs show one ATA100 slot (2 Devices) BUT - 8- SATA slots.

I have two SATA hard drives & 2 run to external plugs, but plenty left.

doktarZues
05-21-2007, 20:42
kimigirl, most of the new mb's these days only have 1 ide connector.. I built a new pc a month ago and I was looking for a mb with 2 ide connector's and I gave up after a while because I couldn't find what I was looking for with two of them. -dok

kimigirl
05-22-2007, 01:39
Thats weird, but then again the last time the company bought the stuff for a new computer was at least a year ago before they went over to the dark side of the force and bought Dells.

Blitzer
05-22-2007, 02:26
Hmmm, IDE bus is getting odd, ditto on testing one drive at a time. I have seen Windows get unruly like that after months of running fine, many times it was the IDE controller at the root of the conflict.

The issue may be that the resources for the second IDE channel may be locked up by other components on the mother board. Try to disable the onboard EIDE controller in BIOS and add a Slot EIDE controller. You will get two more EIDE channels and another bus connector.

:thumbsup: :supergrin: ;)

aaronrkelly
05-22-2007, 02:27
If it only locks up when inserted but reads fine after a reboot then its software, has to be.

What broken hardware device would operate like that? None that I know of.

Philipp2
05-22-2007, 11:13
I am hoping to go by there and run thru a series of tests, plugging in one at a time - see if anything works then. One suggestion received is that the firmware on one of the drives is corrupt. Don't know about that one. About the only thing that is common to both drives is the cable and the IDE controller. ???

kimigirl
05-23-2007, 03:06
If they are on the same line, a corrupt or damaged drive could cause the problem but because it works fine after a reboot, I don't believe the drives themselves are the issue. Check the IRQ's for conflict, and if that doesn't work, try reinstalling the Primary IDE Controller in Device Manager.

Philipp2
05-28-2007, 21:02
Had a few minutes today and stopped in to try and isolate the problem with the drives:
1. Unplugged one drive, rebooted, same problem - machine totally locked up, had to hold in the power button to shut it down.
2. Unplugged second drive & plugged the first back in - same problem.
3. Removed the round IDE cable and replaced with the OEM ribbon cable - same problem.

Left CD in and rebooted - worked OK, same as before. Replaced CD and computer locks up when trying to read CD.

Did a REGEDIT and reset "AUTORUN" from a "1" to a "0" - Off
Computer does not lock up (Or read) new CD, but you can right click on drive, explore and click on executable file - it runs fine.

kimigirl suggests reinstalling the Primary IDE Controlled in Device Manager. I would like to do that, but am not 100% sure how to. Does that program come on the MB hardware disk? If so, wouldn't the drive be inactivated after unstalling the driver?

kimigirl
05-28-2007, 22:08
Go into Device Manager. You will see the entry for the Primary IDE controller. Right click on it and choose uninstall. Reboot the combuter. 99% of the time it finds the correct driver and reinstalls it without issue. If for some reason it does not reinstall it, you can usually go the motherboard manufacturers website and get the device drivers from there.
If that doesn't work, you might check to see if there is an entry for a secondary IDE controller also.