96 GMC sierra lights pulsing. [Archive] - Glock Talk

PDA

View Full Version : 96 GMC sierra lights pulsing.


Steel Talon
09-23-2007, 11:12
Hello,

Any ideas why my 96's lights are pulsing while driving at night? (Panel ligts,headlights and running lights)

* Daylight driving lights are not working.
* The battery panel light is also intermitently pulsing on an off.

I'd like to have an idea of the possible problem before I seek out $$ervice, or fix it myself.

Thanks
ST~

NotAMonte86
09-23-2007, 11:19
Low voltage while driving, probably a bad alternator. Maybe a bad battery as well. Go to AutoZone and have them check it out. That will give you a much better idea.

Does your a/c work fine? Less common, but could be a loose accy belt due to a sticking idler adjustment. You could check this by hand.

knightkrawler00
09-23-2007, 15:20
I'd lean towards low output from the alternator as NotAMonte86 already pointed out. It could also be a poor ground or loose connection also. The side post batteries in those trucks are known for breaking off, yours could be getting to that point. Before they break, they usually leak. This will cause a lot of corrosion and resistance and possibly chewing up the wiring under the battery if the leak is bad enough. Check the grounds bolted to the front of the frame for being clean and tight, as well as the grounds that go to the block. There is one on the drivers front low on the block, and one on the rear of the passenger side cylinder head.

I'd check, in order. The alternator, battery, then move to wiring issues.

NotAMonte86
09-24-2007, 17:45
Good point, forgot how pathetic Delco batteries are (if that's what you have). Check that positive battery terminal for leaking acid/corrosion. If it's left to leak, it will start to ruin the positive battery cable.

Steel Talon
09-24-2007, 19:41
Hello Fellas,

Thanks for the information..

I tend to keep the engine compartment very clean so I can notice leaks etc. Almost looks as good as when it came off the showroom.:)
Anyway visually the battery seems fine, no visible problems leaks or loose posts. Water level in battery is good. This battery is 3 years old and is prorated for 8 total(Auto Zone battery).Water level in battery is good. The battery It replaced had a loose positive post..

Cables (side post, hate em) look ok. I checked for solid tight connections this evening. The battery idot panel lite flickering that was sporadic is now not occuring.

I will check the frame and block grounds tomorrow. Saturday I plan take it to Auto Zone for a system check

Last year the sysyem to pulse, but I discovered that the license plate lights had burned out, Once I replaced the bulbs the pulsing stopped.

Do apreciate the help!!

Peace
ST~:cool: