Got home-brewed Leenuks on a laptop? [Archive] - Glock Talk

PDA

View Full Version : Got home-brewed Leenuks on a laptop?


Tennessee Slim
05-07-2008, 08:58
If you're running (non-preinstalled) Leenuks on a laptop, have you had to edit your xorg.conf to configure your touchpad? Would you mind posting the details?

My "traveling" laptop is now Leenuks, OpenSUSE 10.3 on a Compaq V2401CL. And the touchpad tends to be spacey. Sometime it acts like it's on speed. A USB mouse works fine but the cursor sometimes acts like someone's set its arse on fire when I use the touchpad.

So I did some research and manually edited he xorg.conf (random changes, shotgun approach). And it pretty much tamed the touchpad ...until I rebooted. Then X-Windows would no longer load. So I restored the original xorg.conf.

Yeah, I can make all the same changes to the xorg.conf one at a time and reboot after each, but I'd sooner have a bikini wax. I was hoping someone here could give me the Cliff Notes version of "the fix".

IndyGunFreak
05-07-2008, 11:54
I disabled my touchpad, cuz I hate them... I know with Ubuntu and Debian, there is a program called "gsynaptics" in the repository, that manages the touchpad. I imagine Suse has something like that available. Its been a long time since I used Suse, but maybe you can apply some of the below to help you out...

https://help.ubuntu.com/community/SynapticsTouchpad

Here's my xorg.conf for my laptop, running Ubuntu 8.04


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
Option "SHMConfig" "on"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Synaptics Touchpad"
EndSection

Tennessee Slim
05-07-2008, 12:17
Thanks, IGF.

Synaptics is managing mine. I was avoiding installing Gsynaptics in deference to the KISS principle, hoping to work through it at a more elementary level. I'll try your xorg.conf settings without the gsynaptics first.

Mercy beer cups! :beer: