3800 gm engine, MAF sensor error? [Archive] - Glock Talk

PDA

View Full Version : 3800 gm engine, MAF sensor error?


WEATHERBY460
06-17-2008, 18:45
my wifes 2002 gran prix has a check engine light, and the scanner said maf sensor, low voltage. I have 12v at the maf, but the output must be flacky. A new sensor is $200, any way I can be sure its that sensor?

I did find the air hose between the throttle body and the air filter, not all the way on, and debris had made it to the screen on the throttle body...i wonder if the debris damaged the sensor.

Any input is great...thanks

IslandHopper
06-17-2008, 18:53
If you found debris and/or loose hoses, then fix that and reset the light. Replace the MAF sensor only if the light returns!

knightkrawler00
06-18-2008, 23:46
I would definately clean the MAF sensor and reset the light as IslandHopper mentioned. If the light comes back, then it's time to dig deeper. It doesn't take much to start causing issues with the MAF. Generally a dirty MAF will set a performance code, rather than the low voltage code, but cleaning is a whole lot cheaper than replacing.

The low voltage code is set when the PCM doesn't see the voltage it thinks it should on the feedback circuit. At certain RPM's, throttle percentage, and manifold pressure, the PCM should see the return voltage within a certain window. If the voltage goes out of this range DTC's start setting, a little out and performance DTC's set, a lot out of range and high and low voltage DTC's set.

Get some good brake cleaner and spray the MAF down good, make sure to blow it out real well with shop air, don't want to leave any of that residue on there. Throw it back on and see if the light stays out.