GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Rating: 3 votes, 4.33 average.

Brand New Gen4 G19 Range Report-Not Happy!

Posted 09-24-2010 at 08:02 by 979murphy

Quote:
Originally Posted by ashecht View Post
Took my brand new Gen4 G19 to the range today for the first time. Used the same Federal 9mm 115 grain ammo I have used in my Bersa, and in my XD9SC. Could NOT get 3 consequtive rounds fired successfully. Stovepipes, rounds not getting fed into the chamber correctly. I have noticed that the new spring does not stay down in the notch of the barrel, but rather begins to creep up. Also notice that the slide gets stuck a bit about 3/4 of the way down when putting it back on the frame. Almost looks misaligned on the frame until you get it all the way on. Very disappointed, after so much success w/my Gen 3 G23. Cannot believe I have to call Glock and probably have to send it to them, after attempting to put 100 flippin rounds through a brand new gun. Very aggravating. I am thinking my choice of a Gen4 over a Gen3 was a bit hasty. What a bummer!

I got my G19 Gen 4 on Aug 25, 2010 and am having the same problems. Sent my pistol to Glock on Sep 13 for warranty repairs. Glock tried to duplicate the problems and inidicated that they can not find any problems with my pistol. Glock shot 60 rounds on the pistol and no problems reported.

I fired 550 rounds on the pistol trying to break it in. Had 34 failures during this period of breaking in the pistol. Failure for every 16 shots fired.

I am disappointed with how Glock is dealing with the problem.
Posted in Uncategorized
Views 15212 Comments 11 Edit Tags Email Blog Entry
« Prev     Main     Next »
Total Comments 11

Comments

  1. Old Comment
    I had a few failures with target ammo. None with +p JHP.
    I hope they resolve your problem quickly. When allowing a new female shooter to fire it, she had several failures. I am assuming that the dbl springs make the gun susceptible to limp wristing.
    Posted 09-29-2010 at 10:11 by txfilmmaker txfilmmaker is offline
  2. Old Comment
    I have been shooting 124 gr fmj and it has worked well so far. A few failures with 115 gr fmj. But overall, the gun is shooting better, I think the recoil spring has loosened a bit.
    Posted 09-29-2010 at 11:07 by 979murphy 979murphy is offline
  3. Old Comment
    Scouse's Avatar
    The spring (Main spring) on the first Gen 4 in 9mm, worked great with +P+ Ranger, not with the lighter target type rounds.

    Complain, they send you a new (lighter? one) then no problem.

    Glock Werx sell a wee grommet that fits in the nose of the slide, allowing the use of earlier model main springs, works fine.
    Posted 10-15-2010 at 04:45 by Scouse Scouse is offline
  4. Old Comment
    Something suggested when I bought my new Gen4 9mm:

    Leave slide open for a few days to keep spring compressed. Use only 124-147gr during the break-in period.
    Posted 10-28-2010 at 21:23 by fn/form fn/form is offline
  5. Old Comment
    ADK_40GLKr's Avatar
    If you follow the Go-Ask-the-Expert "Glock Pistol Forum" they have a stock answer for that issue: "heavier bullet or lighter spring; break-in with 100 rds of 124 gr, and don't limp-wrist"
    Posted 11-25-2010 at 16:36 by ADK_40GLKr ADK_40GLKr is offline
  6. Old Comment
    keep it simple - just get the new spring
    Posted 12-21-2010 at 13:15 by johnchitown johnchitown is offline
  7. Old Comment
    Scouse's Avatar
    I have been shooting 9mm Glocks, since 1984, never had a stove pipe till I bought Gen 4 Mod 19s, I have the latest sprngs "04".

    Solution. Use Gen 3 springs, mod; them to have the fitting that will go in Gen 4 slide noses!

    Fixed.
    Posted 12-21-2010 at 14:30 by Scouse Scouse is offline
  8. Old Comment
    Here's my range report on my new G19 Gen4:
    Prep for first trip to range; Lubed in strict compliance with Glock instructions as on Glockmeister web site. Did not remove the copper lube. Replaced stock Glock sites with Trijicon night sights. Spring was marked 0 3.
    350 rounds of WWB, no FTE and no FTF.
    Fit was very comfortable in my small hands without any of the backstraps. Found the mag release size almost perfect for me.
    My Gen 3 19 has the Glock OEM '-' connector and the extend mag release by glockmeister and the Glock OEM extended slide stop. Will add the '-' connector and extended slide stop to the Gen 3.
    Posted 12-28-2010 at 19:35 by seaking11 seaking11 is offline
  9. Old Comment
    Took my new Glock 19 Gen 4 to the range it sucked!!! I have a Kel-Tec PF 9 that shot without failures with the target rounds that I used in my Glock. In all fairness the 19 did shoot the Plus P 147 grain Winchester BHP flawlessly. Who the heck wants to put your expensive rounds down range when you have the cheap Wal-Mart rounds to shoot for target shooting!! AT least it shot my carry rounds good but my confidence for the Glock as a carry weapon is low. So the target ammo was Federal 115 grain $10 a box ammo. I shot 150 rounds to try and break it in and around 50 were jams. The slide would not even lock back after shooting the last round this happened 4 times. Staggered the 115 grain and the 147 grain it would jam after it shot the 115 grain. I call Glock and explained to them what was going on and they said they have been receiving calls about this and would send me a lighter recoil spring. Glock has a problem with the Gen 4 19 but has not put it out to inform the shooters unless you call them yourself. I love Glocks but they are starting to screw up.
    Posted 01-04-2011 at 13:29 by glock21ssp glock21ssp is offline
  10. Old Comment

    check your slide release lever

    [QUOTE=glock21ssp;bt220]Took my new Glock 19 Gen 4 to the range it sucked!!! I have a Kel-Tec PF 9 that shot without failures with the target rounds that I used in my Glock. In all fairness the 19 did shoot the Plus P 147 grain Winchester BHP flawlessly. Who the heck wants to put your expensive rounds down range when you have the cheap Wal-Mart rounds to shoot for target shooting!! AT least it shot my carry rounds good but my confidence for the Glock as a carry weapon is low. So the target ammo was Federal 115 grain $10 a box ammo. I shot 150 rounds to try and break it in and around 50 were jams. The slide would not even lock back after shooting the last round this happened 4 times. Staggered the 115 grain and the 147 grain it would jam after it shot the 115 grain. I call Glock and explained to them what was going on and they said they have been receiving calls about this and would send me a lighter recoil spring. Glock has a problem with the Gen 4 19 but has not put it out to inform the shooters unless you call them yourself. I love Glocks but they are starting to screw up.[/QUOTE]

    check to see if your slide relese spring is in the right position. when your looking inside your lower reciver with the slide off the top of the spring must rest right under the locking block pin. If the spring is not visiblely resting underneathe the pin your wepon is not put together right and will cause it to have major maulfunctions.
    Posted 01-22-2011 at 19:09 by j_roc j_roc is offline
  11. Old Comment
    Check the slide release spring its good to go. I shot another 250 rounds and I had only 15 FTF and the slide failed to lock back after the last round was shot 8 times. I used the monarch ammo 115 grain and it seem to feed those better. I rapid fired some winchester 127 BHP plus p 15 round full mag and it fired flawless. Then I shot the same plus p ammo slow fire flawless so the plus p is good to go. I did some research and one thing I did was lock my slide back for 2 days and I think that may of helped. I just got the spring that glock said they would send me for free so that was cool. The original has a 04 on the back plate of the recoil spring and the reduced recoil spring that golck sent me has a 03 on the back plate. Have not had a chance to test fire it though. Will send an update after I get a chance to shoot it.
    Posted 01-22-2011 at 21:22 by glock21ssp glock21ssp is offline
 

All times are GMT -6. The time now is 23:52.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 879
216 Members
663 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31