Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

979murphy 979murphy is offline

Junior Member

About Me

  • About 979murphy
    Biography
    glock 19 owner
    Location
    wisconsin
    Interests
    basketball, reading
    Occupation
    accountant

Statistics

Total Posts
Blog
General Information
  • Last Activity: 06-12-2013 19:23
  • Join Date: 05-10-2005
  • Referrals: 0

Blog

View 979murphy's BlogRecent Entries
Latest Blog Entry

Posted 09-24-2010 at 08:02 by 979murphy Comments 11
Posted in Uncategorized
Quote:
Originally Posted by ashecht View Post
Took my brand new Gen4 G19 to the range today for the first time. Used the same Federal 9mm 115 grain ammo I have used in my Bersa, and in my XD9SC. Could NOT get 3 consequtive rounds fired successfully. Stovepipes, rounds not getting fed into the chamber correctly. I have noticed that the new spring does not stay down in the notch of the barrel, but rather begins to creep up. Also notice that the slide gets stuck a bit about 3/4 of the way down when putting it back on the frame. Almost looks misaligned
...
Recent Comments
Check the slide release...
Posted 01-22-2011 at 21:22 by glock21ssp glock21ssp is offline
[QUOTE=glock21ssp;bt220]Took...
Posted 01-22-2011 at 19:09 by j_roc j_roc is offline
Took my new Glock 19...
Posted 01-04-2011 at 13:29 by glock21ssp glock21ssp is offline
Here's my range report...
Posted 12-28-2010 at 19:35 by seaking11 seaking11 is offline
I have been shooting...
Posted 12-21-2010 at 14:30 by Scouse Scouse is offline



All times are GMT -6. The time now is 08:03.