Glock Talk

Glock Talk (http://glocktalk.com/forums/index.php)
-   Tech Talk (http://glocktalk.com/forums/forumdisplay.php?f=86)
-   -   Linux Gurus, need some help (http://glocktalk.com/forums/showthread.php?t=274913)

Alpha752 08-11-2004 10:31

Linux Gurus, need some help
 
Hello all, I have dual booted my XP box with Mandrake 10. I am a total noob with Linux, and am trying to learn the system. Trial by fire is the best way.

I am having trouble Installing Kernel-Source code. I need to do this to install some drivers for my wireless reciever (netgear ma111). The instructions I have are:
Installing Kernel-Source (required for driver installation):
2.Open the console and type:
a.“su” --> enter the root password.
b.“urpmq -r kernel-source”; this should display:
--> kernel-source-2.6.3-7mdk
c.“urpm –i kernel-source-2.6.3-7mdk.rpm” – substitute if the disk used has a later version. Note: only the version shown has been tested.
d.“mkdir /usr/src/linux/.tmp_versions” --> note: driver installation will fail if this directory isn't created.

Everyting goes OK untill I hit C. I assume that urpm-i is a typo and he means urpmi. When I type that, it gives me an error (cant find file, or something like that, I cant remember exactly). I do have a diffrent kernel then the instructions above (2.4.25-2mdk).

Any suggestions for how to proceed? I appreciate anything you can offer.

Russ

Alpha752 08-11-2004 10:37

Also, I tried to install the kernel from inside the GUI (KDE), as suggested on another forum, and it asked for CD 4. I dont have a CD 4, only the 3 .iso's. ;P ;g ;1

HerrGlock 08-11-2004 10:39

Mandrake seems to have an rpm command that I'm not familiar with, but...

I assume you're using bash as a shell?

Type this (literally, dollar sign capital shell):
echo $SHELL

You should get back something like this:
/bin/bash


If you're using bash or tcsh, you will have command completion. A lot of problems are caused by "fat fingering" commands and mistyping. Command completion helps worlds with this.

First, you must be in the directory the kernel source rpm is in.
type
ls

and see if the kernel-source rpm is in there.

if it is not, cd to the directory with the source rpm in it.

On your command "C" type
urpm -i kernel-source
do not hit enter. hit the tab key and see if it completes the rpm file for you. If it does, then hit the enter key.

The "-i" in the urpm command means "Install" and is not part of the command, it's a switch.

type
man urpm
and read the page to see what's going on. Type "q" to exit the man page.

DanH

David_G17 08-11-2004 11:49

Quote:

Originally posted by HerrGlock

type
man urpm
and read the page to see what's going on. Type "q" to exit the man page.

DanH

or try
info urpm

:)

Alpha752 08-11-2004 11:52

So it IS urpm -i??? OOOOOOO

Quote:

I assume you're using bash as a shell?
Huh? Im using the Konsole in KDE (if thats even what your talking about.

Thanks guys, I will try your suggestions tonight when I get back home, and report back.

Russ

David_G17 08-11-2004 11:59

Quote:

Originally posted by Alpha752
So it IS urpm -i???
urpm is probably specific to mandrake. the man (short for manual) page and the info page will tell you what parameters can be passed. i image "-i" means to install, but i don't have a copy of Mandrake to check it out.

http://mandrakeuser.org/docs/basics/brpm3.html

it appears the command is urpmi

nothing 08-11-2004 12:37

I'm not too familair with MDK 10, but I know mdk 9 still had rpm as well as urpm. I would assume it still has both. Try rpm -ivh kernel-source-2.6.3-7mdk.rpm or urpm -ivh. Post the exact error message here. It could be a dependency problem. You might also want to try putting the full path to the file ie.

rpm -ivh /home/user/mycooldownloads/subfolder/kernel-source-2.6.3-7mdk.rpm

Alpha752 08-11-2004 22:52

1 Attachment(s)
Well guys, I fiddled around with it, and found a copy of the CD4 iso, so I used that to install the kernel source. The driver install went fine after that, but I hit another road block. Im attaching a copy of my instructions so you can see the whole thing.

I get down to the point that says "copy the ifcfg-wlan0 network-script to the /etc/...

When I do the command shown, I get "Can not stat ifcfg-wlan0. No such file or directory."

So now, Im so close, and cant go any farther. Can anyone help?

TIA,
Russ

nothing 08-11-2004 23:25

make sure you are in the directory containing ifcfg-wlan0. Be sure you are typing the file name correctly. Linux is case sensitive. Tab completion is a great tool if you don't already know about it. Just type part of the file and press tab. Works the same with directories and commands. This will complete the entry.

try this:

cp -v ./ifcfg-wlan0 /etc/sysconfig/network-scripts/

I have a feeling you might not be in the correct directory. Basically it's telling you the file doesn't exist in the location you're asking it to look.

If that doesn't work try the full path to the file

cp -v /home/user/directoryoffile/ifcfg-wlan0 /etc/sysconfig/network-scripts/

Alpha752 08-12-2004 11:36

Ok, I cant find this file anywhere. I searched the whole /. It is nowhere to be found. Would it be easier to just get another adapter? I know about as much about wireless networks as I do about Linux (combined, my knowledge is NOTHING).

Can I get a non netgear adapter to work with my Netgear 80211.b router? Can you suggest an adapter that will FOR SURE, work with mandrake 10, and will FOR SURE connect to my router? I would prefer to avoid PCI cards because my PC is in the basement, and the router is upstairs. The signal is lower toward the floor (where the PC is). Currently I have my USB reciever on a 6' extender, close to the ceiling.

So, if this isnt going to work out, is there an adapter that will? HELP! I really wanna start using Linux more, but 90% of my computer usage is on the internet.

Thanks for all the help so far.

Russ

Alpha752 08-13-2004 23:11

1 Attachment(s)
Well, I got it working (im posting from linux). I ended up getting a new card, so now im online. I even downloaded, untarred, and installed Firefox. Im on my way to accually knowing what this is all about.

And attached is the obligitory GT on KDE pic.

Thanks for you help, Im sure ill have a million more questions in the future.;c ;c ;c

Russ

(I guess this adds another question. Any free picture hosting that will work with linux? I was using freepichosting.com but they have windows only software. I tried to use yahoo, but you cant use the img tag with yahoo.)


All times are GMT -6. The time now is 23:46.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright ©2013, Glock Talk, All Rights Reserved.