Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-28-2010, 15:26   #1
Randy from Kansas
Senior Member
 
Randy from Kansas's Avatar
 
Join Date: Mar 2009
Location: kansas
Posts: 363
AR-15 Extractor Problem?

Dear Sir
I am having a problem with my Colt Match Target Rifle Model MT 6601 after firing between 5000 and 7000 rounds it developed a problem of failure to eject the spent brass from the chamber. The extractor does not damage the brass but pulls over the rim. I have installed new spring O-ring and extractor. The ammo I am using is my reloads using Remington brass Full length sized with 55 V-max bullets. Since the rounds chamber just fine I have not tried small base dies. I clean the chamber every time I clean the gun using a chamber brush and am at a loss as to what to replace next.
I have also fired Wolf ammo and S&B with the same problem. Normally it will stick a case after 60 to 90 rounds have been fired. The problem developed within the last 1000 rounds being fired
Any help would be appreciated

Thanks Randy
__________________
A good plan violently executed now is better than a perfect plan executed next week.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
Randy from Kansas is offline   Reply With Quote

 
  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 07:17.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 863
267 Members
596 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31