GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-01-2010, 09:32   #1
mitchg233
Senior Member
 
Join Date: Dec 2007
Posts: 173
P6 problem(s) update

No doubt the two issues are related. My friend was shooting the P6 that I advised him to buy, and which he is pleased with overall. he was half way through a magazine when the trigger appeared not to reset. No click, no bang. I looked at it at that point and indeed the trigger, although it seemed to be in the correct position for a SA shot, was not engaging anything on the pull. My friend racked the next round into place and the gun fired normally, and continued to for another ten or so rounds. Then, the same issue occurred, and he racked it again, expecting the gun to fire on the new round. HOWEVER, at this point, although the trigger did indeed drop the hammer on the new round, it did not fire. He recocked the hammer with his thumb and tried again 3-4 times, at which point I suggested we look at the round. I expected it was simply a failed primer, but on inspection there was NO imprint of the firing pin on the primer, even after those repeated attempts.

I brought the gun home and fieldstripped, cleaned, checked function as much as I know how, and reassembled. Dry firing does not show any problems, and when the gun is apart and the safety lock is depressed, the firing pin seems to have full range of motion, and the end does not appear damaged. I don't think this gun has experienced a pierced primer. I am headed back to the range today, but just going on hope at this point.

BTW, springs are original and DA pull is very stiff, which I expect is normal. Any thoughts would be appreciated.

Last edited by mitchg233; 06-03-2010 at 20:40..
mitchg233 is offline   Reply With Quote

 
  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 06:51.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,040
268 Members
772 Guests

Most users ever online: 2,244
Nov 11, 2013 at 16:42