Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 06-28-2012, 20:32   #1
PghJim
Senior Member
 
Join Date: Apr 2005
Location: Pittsburgh
Posts: 1,804
Trijicon RMR Reliability????

I was wondering if anyone else has been experiencing the failures I have with the Trijicon RMR's; RM07 in my case. I have three RMR's. Two are on G19 milled slides and one is on a G32 milled slide. The red dot went out while shooting one of the G19's so I sent it back. When I received the fixed sight back, the red dot went out on the third shot. It would be on for two shots and off for two shots. So I sent that back with no word yet. It had about 300 rounds through it.

The other one on the G19 would not hold the adjustment at all. After optaining the desired position it would take about 20 shots for it to move excessively, up to 6 inches at 15 yards. I send it back today and it had less than 300 rounds through it.

I have not shot the one of the G32 slide much, so I do not know if it will hold up. I thought these sights were ready for the rigors of combat.
PghJim is offline   Reply With Quote
Old 06-29-2012, 05:20   #2
DannyR
Moderator
 
DannyR's Avatar
 
Join Date: Dec 1998
Location: Roanoke, Virginia
Posts: 38,339
Optics mounted directly to slides take a real beating. I prefer using scope mounts, like Carver, which keep the optic stationary while the slide cycles.
__________________
Lifetime GSSF Member
Certified Glock Armorer 1997-2015
NROI, Level I
Bull Dawg #1

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
DannyR is offline   Reply With Quote
Old 06-29-2012, 06:11   #3
PghJim
Senior Member
 
Join Date: Apr 2005
Location: Pittsburgh
Posts: 1,804
I understand that, but if you advertise them as compatable with slide mounting, they should work. The response is light, does anyone have RMR's mounted to their slides?
PghJim is offline   Reply With Quote
Old 06-29-2012, 07:49   #4
Mark Housel
Senior Member
 
Join Date: Dec 2011
Location: Arizona
Posts: 149
Quote:
Originally Posted by PghJim View Post
I understand that, but if you advertise them as compatible with slide mounting, they should work. The response is light, does anyone have RMR's mounted to their slides?
I have personally installed hundreds of RMR's on various slides (Glock, M&P, XD, etc).

I have had a few people call me about the dot going out when firing/dry firing.

Most are due to the older style battery contacts that are both situated such that they can touch the slide. Tape placed on the slide takes care of that.

The one other was the newer style and when the customer returned it to Trijicon they indicated that they found something wrong and replaced the electronics (not sure they didn't swap out the whole sight?).

There have been reports of some RMR's not holding zero. I have not had a customer report that problem to me.

Having a background in manufacturing I can certainly see how a batch of these with somehow less robust detents on the adjusters could have gotten out and missed by whatever QC process was in place.

I have to believe that Trijicon is aware of this and has much more data on the actual failure rate and the ability to track batches to help understand the scope and cause of the problem.

Some people put witness marks on the dial and some retain it with a small drop of RTV or the like.

But no, they shouldn't move.

I can see that what might actually be a overall very reliable and high quality product doesn't look like that from your perspective with two bad units.
Were these all the same model?
Were these purchased at the same time?
Close serial numbers?
__________________
================================================
FFL Type 07

"I have learned that wisdom can be as simple as substituting facts for assumptions."
Mark Housel is offline   Reply With Quote
Old 06-29-2012, 07:55   #5
500WE
Senior Member
 
Join Date: Feb 2007
Location: South of Yancey's Bluff
Posts: 213
I have had both good and not so good results with the RW07. The first one that I had, I never mounted and appeared to have been previously used.
It would kill its battery in two days with the adjustable brightness on a moderate setting.

I returned it to the dealer for exchange.

The replacement has had at least 500 rounds under it on a G17 with a TSD slide and no problems at all. It has been a most excellent choice.

I have another RM07 mounted on a TSD G19 slide with about 400 rounds of all types of ammo from plinking to +P+ through it and no problems either. This is my current favorite shooting choice and will probably see some range time today.
500WE is offline   Reply With Quote
Old 06-29-2012, 16:29   #6
PghJim
Senior Member
 
Join Date: Apr 2005
Location: Pittsburgh
Posts: 1,804
Mark installed the only one that has held up so far. This is really troubling to me. When you send one back because the dot keeps going out and you get it back and the first thing that happens is that the dot goes out.

After I adjust a unit, I put a thin strip of electrical tape over the adjusters so they do not move. According to the SN's they are a 1,000 units apart. If you have not gone this route yet, you may want to hold off until more comes out.

The batteries are firmly in place and the units are mounted well. I also put electrical tape over the down side of the battery so it does not contact the slide.

Something else everyone should know. There is a piece of glass/plastic covering where the red dot is projected. If this get dirty, it will project what look like scratches on the main lens. I use soft Q-Tip and water to clean and dry.

Last edited by PghJim; 06-29-2012 at 16:30..
PghJim is offline   Reply With Quote
Old 06-30-2012, 20:36   #7
racer88
NRA & SAF mbr
 
racer88's Avatar
 
Join Date: Oct 2009
Posts: 2,373
I have the RM07 mounted on an FNH FNP-45 Tactical. I can't give you an exact round count, but I'm guessing 500 - 1000 rounds.

I haven't had any issues at all, except the mounting screws coming loose. So, now I've used some locktite to keep'em in place. It's also my primary HD pistol. So, it sits in my Gunvault with the RM07 left turned on. It's been that way for months. I've got it set an "auto" for the brightness.

Sights, Optics and Lasers
racer88 is offline   Reply With Quote
Old 06-30-2012, 22:51   #8
MikeSantor
Senior Member
 
Join Date: Mar 2012
Location: FEMA region 5
Posts: 128
I can not speak for the RMR07 but I have an RMR02. Since April of '11 I have over 8k rounds with it used on an FN Fiveseven and now most recently thanks to Mark 500 rounds with it on a G17 and it has never once had a problem and even after taking it off a few times continued to hold a zero on the fiveseven.
MikeSantor is offline   Reply With Quote
Old 07-26-2012, 11:58   #9
500WE
Senior Member
 
Join Date: Feb 2007
Location: South of Yancey's Bluff
Posts: 213
Well my batting average just dropped a bunch.
I recently installed an RM07 that I bought in late April. It went on a complete slide assembly that I bought in early July. Last week it just completely died after beginning to lose its mechanical settings.

That was after about 300 rounds it is now on the designated RMA list. I hope that Trijicon will say what was wrong when it is returned. They state about a 4 to 5 week turnaround currently. Makes one wonder if there have been some engineering changes.
500WE is offline   Reply With Quote
Old 07-26-2012, 17:58   #10
jdsumner
Senior Member
 
Join Date: May 2005
Location: riverview, florida
Posts: 974
I'm up around 5k (min) with no issues.

dan
jdsumner is offline   Reply With Quote
Old 07-26-2012, 18:26   #11
lostone1413
Senior Member
 
Join Date: Jan 2004
Posts: 125
Mark put an RMR RM07 on my Glock 19 It works great Thanks Mark!
lostone1413 is offline   Reply With Quote
Old 07-27-2012, 09:51   #12
dcc12
Senior Member
 
Join Date: Nov 2010
Posts: 342
I am wanting to put one of these on a G23. I need to know if anyone else is running one and how they like it. Also what holster are you using.
dcc12 is offline   Reply With Quote
Old 07-27-2012, 12:24   #13
lostone1413
Senior Member
 
Join Date: Jan 2004
Posts: 125
Quote:
Originally Posted by dcc12 View Post
I am wanting to put one of these on a G23. I need to know if anyone else is running one and how they like it. Also what holster are you using.
Mark put a RMR RM07 on a Glock 19 for me Now I hit things I couldn't hit at 20. Being in my mid 60s I can say I'm more then pleases with the RMR As far as a holster goes this is what I use that only one I would use http://www.dalefrickeholsters.com/products.htm
lostone1413 is offline   Reply With Quote
Old 08-04-2012, 06:10   #14
PghJim
Senior Member
 
Join Date: Apr 2005
Location: Pittsburgh
Posts: 1,804
Quote:
Originally Posted by 500WE View Post
Well my batting average just dropped a bunch.
I recently installed an RM07 that I bought in late April. It went on a complete slide assembly that I bought in early July. Last week it just completely died after beginning to lose its mechanical settings.

That was after about 300 rounds it is now on the designated RMA list. I hope that Trijicon will say what was wrong when it is returned. They state about a 4 to 5 week turnaround currently. Makes one wonder if there have been some engineering changes.
I have had 3 go back and it is only a 3 week turnaround, except for the replacement one, which took 6 weeks. I am a little concerned. The replacement one looks and feels better than the rest. One thing I found out about RMR mounted to milled slides. Be sure the screws are short enough so they do not bottom out when mounting. I think that may have been a problem with one of mine that was not holding the setting. I shortened the screws and all seems OK so far.

I have had no issues with the one Mark installed, so the installation may be critical, like being sure the screws are the proper length.

Last edited by PghJim; 08-04-2012 at 06:13..
PghJim is offline   Reply With Quote
Old 08-04-2012, 09:31   #15
Mark Housel
Senior Member
 
Join Date: Dec 2011
Location: Arizona
Posts: 149
Quote:
Originally Posted by PghJim View Post
I have had 3 go back and it is only a 3 week turnaround, except for the replacement one, which took 6 weeks. I am a little concerned. The replacement one looks and feels better than the rest. One thing I found out about RMR mounted to milled slides. Be sure the screws are short enough so they do not bottom out when mounting. I think that may have been a problem with one of mine that was not holding the setting. I shortened the screws and all seems OK so far.

I have had no issues with the one Mark installed, so the installation may be critical, like being sure the screws are the proper length.
I still wonder if there was somehow a bad "batch" of internals that somehow escaped or suffered some sort of infant mortality problem.

One way to insure that the screws are holding properly is to snug up one screw and verify that the RMR is solid.

Then loosen that one and snug the other one and re-check the RMR.

Then loctite and final tighten both screws.

The screw over the extractor can also be too long and bind the extractor rod.

If the left side factory length screw is too long then the threads most likely aren't deep enough.
__________________
================================================
FFL Type 07

"I have learned that wisdom can be as simple as substituting facts for assumptions."
Mark Housel is offline   Reply With Quote
Old 08-04-2012, 10:06   #16
500WE
Senior Member
 
Join Date: Feb 2007
Location: South of Yancey's Bluff
Posts: 213
Mine were/are installed correctly with the corrected length screws for a Glock that were supplied along with the sight by a shop that has installed a lot of these. Correct seating depth was verified before I also used the proper amount of thread locker in addition to the locker already on the screws. Nothing in the install was moving external to the sight's internals.

I didn't want to wait the Trijicon stated 4 to 5 weeks so I got another to smooth out the wait. This one is in the 80k serial # range and came in a larger, black case. The dead one is in the 76k range and came in a smaller clear case as did the others that I have seen. It is mounted on the same slide with the same screws with the same battery as the previous one.

As of yesterdays range visit it has about 300 rounds under it and is behaving very well so far.


Last edited by 500WE; 08-04-2012 at 10:21..
500WE is offline   Reply With Quote
Old 08-04-2012, 10:18   #17
500WE
Senior Member
 
Join Date: Feb 2007
Location: South of Yancey's Bluff
Posts: 213
When the RM07 gets back from its RMA trip, it and a G29 slide will be going to Mark for an install and a slide cover as well.

The sight will feel as if it is back home for a brief visit.
500WE is offline   Reply With Quote
Old 08-04-2012, 17:48   #18
MikeSantor
Senior Member
 
Join Date: Mar 2012
Location: FEMA region 5
Posts: 128
Quote:
Originally Posted by 500WE View Post
When the RM07 gets back from its RMA trip, it and a G29 slide will be going to Mark for an install and a slide cover as well.

The sight will feel as if it is back home for a brief visit.
This is currently the set up I want OHH so bad. G29G4 with triji from Mark. IMO, the ULTIMATE cc pistol.

Please post pics when you get her done.
MikeSantor is offline   Reply With Quote
Old 08-05-2012, 07:37   #19
500WE
Senior Member
 
Join Date: Feb 2007
Location: South of Yancey's Bluff
Posts: 213
OOPS - My bad - it is a G21 RTF2 - sorry about that - haste makes waste.

500WE is offline   Reply With Quote
Old 08-25-2012, 08:14   #20
500WE
Senior Member
 
Join Date: Feb 2007
Location: South of Yancey's Bluff
Posts: 213
Trijicon "did good".

They received my RM07 on 8/14 and had it back in UPS hands on 8/21. The shipper that came with it stated "Replaced electric". Looks good as new.
500WE is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 04:20.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 611
156 Members
455 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31