Important Notice: The site is currently being upgraded to a new software system. This process could take a day or two to complete. During that time, we are going to leave the site up here, on its old software. WHAT GETS POSTED HERE DURING THIS TRANSITION WILL NOT BE COPIED OVER ONTO THE NEW SITE, WHEN THE UPGRADE IS COMPLETE. When we swap over, the content posted while this message is visible will be lost. We wanted to give you folks a place to hang out and talk while we worked though. We will let you know when we are finished. Please pardon the inconvenience, during this transition.

Home Forums Classifieds GT Store Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-27-2013, 09:34   #1
maddy345
ΜΟΛΩΝ ΛΑΒΕ
 
maddy345's Avatar
 
Join Date: Dec 2009
Posts: 243
Glock 22 gen 3 with X300 issue

I picked up a Glock 22 gen 3 police trade in for $299 and put an X300 on it to use it as a truck gun.

So far no problems with reliability but can anyone tell me if Glock ever figured out what caused the failures with gen 3 Glock 22s with lights attached?
__________________
ΜΟΛΩΝ ΛΑΒΕ

HK Club Member #345
maddy345 is offline   Reply With Quote

 
  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 22:32.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds
GT Store


Users Currently Online: 765
209 Members
556 Guests

Most users ever online: 4,867
May 19, 2015 at 1:03