Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 10-21-2013, 10:46   #1
97XJ_Sport
Senior Member
 
Join Date: Oct 2010
Location: DeSoto, TX
Posts: 371
AR stopped firing.

I was shooting the AR I just built for the first time yesterday, and for the first ten rounds it worked flawlessly, but when I put in another magazine and pulled the trigger nothing happened. I just heard the click of the hammer. It also failed to extract anything after that first ten round magazine. There were no primer strikes on the primers. Does that sound like an issue with the bolt?
97XJ_Sport is offline   Reply With Quote
Old 12-22-2013, 12:12   #2
Constructor
GT Sponsor
 
Join Date: Dec 2009
Location: Roaming
Posts: 519
It sounds like something stuck on the bolt face keeping the bolt from fully locking behind the extension lugs and snapping over the rim of the cartridge in the chamber.
__________________
AR15Performance
Hi perf barrels and bolts
8 twist, 5R, Melonite, Wylde chamber
Constructor is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 18:51.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,028
307 Members
721 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31