Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 01-05-2010, 12:33   #1
allen.m
Member
 
Join Date: Sep 2009
Posts: 91
problem with ar

I went shooting with a friend this weekend and we were shooting his ar and it would fire but failed to eject the spent case unless you remove the mag and thin it would remove that case. i am new to ar's and so is he what could be the problem? The gun is clean.

thoughts please
allen.m is offline   Reply With Quote
Old 01-05-2010, 13:03   #2
SilverBullet_83
NRA member
 
Join Date: Nov 2008
Location: Clermont, Fl
Posts: 780
what mags, ammo are being used. Is the gun lubed correctly. I am new to ARs as well but this stuff comes to my mind
__________________
G36, G19, Stag Model 2
Florida Glockers #121 Black Rifle Club #1121
SilverBullet_83 is offline   Reply With Quote
Old 01-05-2010, 13:22   #3
faawrenchbndr
CLM Number 281
The Dude Abides
 
faawrenchbndr's Avatar
 
Join Date: Nov 2005
Location: east of East St. Louis
Posts: 33,615
Was the round still in the chamber?
Or was it basically jammed on top of the top round in the mag?
Need more specific details if you can provide them.
faawrenchbndr is offline   Reply With Quote
Old 01-05-2010, 13:53   #4
KillStick
Senior Member
 
KillStick's Avatar
 
Join Date: Dec 2008
Location: Corn fields
Posts: 762
I have had some problems like this with wolf ammo....
__________________
1911Addicts.com

KillStick is offline   Reply With Quote
Old 01-05-2010, 14:14   #5
allen.m
Member
 
Join Date: Sep 2009
Posts: 91
The brass was left in the chamber and the next round was trying to feed into it.the gun was lubed as suggested in the manual and i was using remington ammo.The mag was what came with the gun.


Quote:
Originally Posted by faawrenchbndr View Post
Was the round still in the chamber?
Or was it basically jammed on top of the top round in the mag?
Need more specific details if you can provide them.
allen.m is offline   Reply With Quote
Old 01-05-2010, 14:15   #6
cyrsequipment
Angry
 
cyrsequipment's Avatar
 
Join Date: Aug 2004
Location: Maine
Posts: 2,531
Bad extractor...
__________________
Shoot it until it stops.
cyrsequipment is offline   Reply With Quote
Old 01-05-2010, 14:24   #7
allen.m
Member
 
Join Date: Sep 2009
Posts: 91
we were only loading 1 round into the magazine after we discovered the issue. after the shot, the spent brass would be left in the chamber and the slide would lock back. if you release the slide and pull the charging handle again, the brass ejects every time. let me know if i need to give more details. this ar has maybe 150 rounds through it total.

Quote:
Originally Posted by cyrsequipment View Post
Bad extractor...
allen.m is offline   Reply With Quote
Old 01-05-2010, 14:34   #8
cj3410
Registered User
 
Join Date: Jan 2010
Posts: 7
I am certainly no expert but I would try either a new extractor or possibly an extractor upgrade kit from a place like bravo company. You could probably start out using the upgrade insert and spring first, then try using the o-ring as well if you continue to have problems. If the rifle is locking back with the empty mag it does not sound like a short stroke issue.
__________________
Glock 23
Kahr PM9
M&P 9mm
S&W 1911 PD
cj3410 is offline   Reply With Quote
Old 01-05-2010, 14:40   #9
allen.m
Member
 
Join Date: Sep 2009
Posts: 91
additionally, using a snap cap, it works every time.
allen.m is offline   Reply With Quote
Old 01-05-2010, 15:00   #10
faawrenchbndr
CLM Number 281
The Dude Abides
 
faawrenchbndr's Avatar
 
Join Date: Nov 2005
Location: east of East St. Louis
Posts: 33,615
Quote:
Originally Posted by cyrsequipment View Post
Bad extractor...
Sounds like you nailed it,.........
The kit in the link below should fix your problem, and give you a few a spare parts.

http://www.bravocompanyusa.com/BCM-S...rade%20kit.htm
faawrenchbndr is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 17:30.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,121
340 Members
781 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31