Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 04-11-2010, 17:18   #1
trukreltrog
Member
 
Join Date: Nov 2006
Location: Oregon
Posts: 35
Glock 20 reload problems?

Glock 20 SF, factory length Storm Lake Barrel, 22lb non captured wolf spring.

Started working up some hot loads for my gun. Got into some malfunction with my loads.

Loaded 10 rnds in a mag. First 4-5 rounds would not be picked up by the slide. Bullet appears to not of been pushed up fast enough by Mag spring.

So first question is, do you guys run Xtra power springs in your mags, for reliability?

Ran some other stuff thru the gun today. Not sure if they were reloads or what. But every round hung up going into the chamber. If I then pulled the slide back 1/8", and let go. It would feed the round into the chamber. I'm thinking maybe the crimp?

Anyone having problems with Storm lake barrels? Maybe my reloads aren't up to snuff yet, I don't know. But I am considering going back to the stock set up, for better reliability.

Any ideas?
trukreltrog is offline   Reply With Quote
Old 04-11-2010, 17:37   #2
Snapper2
Senior Member
 
Snapper2's Avatar
 
Join Date: Feb 2008
Location: s.east Texas
Posts: 2,357
Quote:
Originally Posted by trukreltrog View Post
Glock 20 SF, factory length Storm Lake Barrel, 22lb non captured wolf spring.

Started working up some hot loads for my gun. Got into some malfunction with my loads.

Loaded 10 rnds in a mag. First 4-5 rounds would not be picked up by the slide. Bullet appears to not of been pushed up fast enough by Mag spring.

So first question is, do you guys run Xtra power springs in your mags, for reliability?

Ran some other stuff thru the gun today. Not sure if they were reloads or what. But every round hung up going into the chamber. If I then pulled the slide back 1/8", and let go. It would feed the round into the chamber. I'm thinking maybe the crimp?

Anyone having problems with Storm lake barrels? Maybe my reloads aren't up to snuff yet, I don't know. But I am considering going back to the stock set up, for better reliability.

Any ideas?
Did you chamber check each round into barrel? what bullets are being used?
Snapper2 is online now   Reply With Quote
Old 04-11-2010, 17:57   #3
trukreltrog
Member
 
Join Date: Nov 2006
Location: Oregon
Posts: 35
180 gr XTP, yes they fit the barrel about the same as a factory round.
trukreltrog is offline   Reply With Quote
Old 04-11-2010, 18:27   #4
Snapper2
Senior Member
 
Snapper2's Avatar
 
Join Date: Feb 2008
Location: s.east Texas
Posts: 2,357
Quote:
Originally Posted by trukreltrog View Post
180 gr XTP, yes they fit the barrel about the same as a factory round.
i have to use a shorter oal for my stormlake barrel 1.250 for xtp. Can you hand cycle the ammo through? I'd measure the rounds after they jam like that. They might be getting set back.
Snapper2 is online now   Reply With Quote
Old 04-11-2010, 20:36   #5
AJE
*goes to 11*
 
AJE's Avatar
 
Join Date: Apr 2004
Location: SW Ohio
Posts: 3,477
Send a message via AIM to AJE Send a message via Yahoo to AJE
I've had some trouble with my KKM conversion barrel. I believe it has to do with the tight match chamber, but it seems to run flawlessly when it is clean, and it seems to have less failures as I put more rounds down the tube. I didn't have any magazine problems, but I did have where the round would go most of the way into the chamber and stop. Pulling back on the slide just a little bit or just pushing it closed would usually work. (24lb recoil spring shouldn't be the problem)

I cleaned the barrel out and shot it today. I put 80 rounds total through it. It ran flawlessly up until about 40-50 rounds. I pulled a bore snake through it several times and then it continued to run without any more failures.

I have no experience with SL barrels but thought my experience might help.
__________________
Certified GLOCK Armorer
17g1, 17g4, 19, 20, 21, 22, 26, 34
AJE is offline   Reply With Quote
Old 04-12-2010, 07:02   #6
trukreltrog
Member
 
Join Date: Nov 2006
Location: Oregon
Posts: 35
Thanks guys, that does help. New to the reloading. AJE, my chamber was dirty also. In the latest round of testing. So maybe that could be the problem with the unknown stuff. Just a dirty chamber. I cleaned the barrel real good. Will get out ASAP to try again.
trukreltrog is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 13:53.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,109
316 Members
793 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31