GlockTalk.com
Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.
Reply
 
Thread Tools Display Modes
Old 05-28-2010, 15:26   #1
Randy from Kansas
Senior Member
 
Randy from Kansas's Avatar
 
Join Date: Mar 2009
Location: kansas
Posts: 363
AR-15 Extractor Problem?

Dear Sir
I am having a problem with my Colt Match Target Rifle Model MT 6601 after firing between 5000 and 7000 rounds it developed a problem of failure to eject the spent brass from the chamber. The extractor does not damage the brass but pulls over the rim. I have installed new spring O-ring and extractor. The ammo I am using is my reloads using Remington brass Full length sized with 55 V-max bullets. Since the rounds chamber just fine I have not tried small base dies. I clean the chamber every time I clean the gun using a chamber brush and am at a loss as to what to replace next.
I have also fired Wolf ammo and S&B with the same problem. Normally it will stick a case after 60 to 90 rounds have been fired. The problem developed within the last 1000 rounds being fired
Any help would be appreciated

Thanks Randy
__________________
A good plan violently executed now is better than a perfect plan executed next week.
George S. Patton
Randy from Kansas is offline   Reply With Quote
Old 05-28-2010, 18:01   #2
Constructor
GT Sponsor
 
Join Date: Dec 2009
Location: Colorado
Posts: 504
It could be a combination of things, the gas port may be eroding letting to much gas enter the carrier increasing the carrier speed. It may also be the case sticking to the chamber wall as it heats up so these 2 things combined could cause the issue.
Has the angle of ejection changed as you have owned the rifle or while shooting it during a session? If the brass is ejecting from 1-3 then you may try an adjustable gas block, I recommend a steel as opposed to alum. or a SSS buffer spring to slow the carrier speed.
__________________
5.56, 6.8, SIX5. The Nexgen of 308s
http://www.AR15Performance.com
Constructor is offline   Reply With Quote
Old 05-30-2010, 08:53   #3
Randy from Kansas
Senior Member
 
Randy from Kansas's Avatar
 
Join Date: Mar 2009
Location: kansas
Posts: 363
Thanks for the answers Constructor. It is ejecting the brass at 4 oclock throwing it 8 to 12 feet to the right and has been since new. When the brass sticks in the chamber I can not remove it without using a cleaning rod down the barrel to tap the brass out the extractor will just slip over the rim of the brass I will hold the gun upright and pull on the bolt carrier and hit the butt of the rifle on the ground sometimes this will eject the brass but most times I have to use the cleaning rod.

Parts I have installed : DPMS Extractor AR-15 and Buffer Technologies Extractor Upgrade Kit AR-15

Thanks
__________________
A good plan violently executed now is better than a perfect plan executed next week.
George S. Patton

Last edited by Randy from Kansas; 05-30-2010 at 09:02.. Reason: added parts installed
Randy from Kansas is offline   Reply With Quote
Old 05-30-2010, 20:04   #4
Constructor
GT Sponsor
 
Join Date: Dec 2009
Location: Colorado
Posts: 504
Laquered wolf cases? if so that may be the problem, I missed that the first time around. I would foam and clean the chamber with everything you have.

Ok, doesn't sound like increased carrier speed so have you trimmed the cases to length lately? Something is causing the cases to stick, it could be long or large dia. cases, a groove or rough spot in the chamber or high pressure. Look at the case for any signs of a rough chamber .
__________________
5.56, 6.8, SIX5. The Nexgen of 308s
http://www.AR15Performance.com
Constructor is offline   Reply With Quote
Old 05-31-2010, 19:13   #5
Randy from Kansas
Senior Member
 
Randy from Kansas's Avatar
 
Join Date: Mar 2009
Location: kansas
Posts: 363
Yes I have fired Wolf with lacquered cases in the past but the last two times out I have not fired any wolf I finally finished off the last of my stock of it. I use Sellier & Bellot and reloads. And to answer your second question yes I trimmed the brass I don't have to after each firing but every third or forth time I do. What bothers me is the fact that the extractor does not damage the brass when it stuck in the chamber. I also have a FAL and when it sticks a shell which has only happened one time it ripped the rim off the brass. When it first started happening I was sure the extractor and spring were worn out but even after installing a new extractor and spring plus an o-ring I still have this problem. Would a different extractor help I have seen a heavy duty extractor advertised but did not know if it would work.

I will get the gun out and Clean it again being extra careful with the chamber to get everything out. Maybe their is some of the Wolf laquered material still hiding in there.

Thanks Randy
__________________
A good plan violently executed now is better than a perfect plan executed next week.
George S. Patton
Randy from Kansas is offline   Reply With Quote
Old 05-31-2010, 21:29   #6
Constructor
GT Sponsor
 
Join Date: Dec 2009
Location: Colorado
Posts: 504
If the cases are sticking enough that you need to tap the cleaning rod to get them out, it sounds like a sticking problem.
A new extractor and spring is cheap from some places(DPMS) and very expensive from others, I saw someone charging $39 for a 7.62x39 extractor Anyway it would be a cheap check.
__________________
5.56, 6.8, SIX5. The Nexgen of 308s
http://www.AR15Performance.com
Constructor is offline   Reply With Quote
Old 06-01-2010, 12:06   #7
Randy from Kansas
Senior Member
 
Randy from Kansas's Avatar
 
Join Date: Mar 2009
Location: kansas
Posts: 363
Sounds like a plan I need to order some parts for another gun and I can just add another extractor and spring to the order.

I think I will give the heavy duty extractor from midway a try

thanks for the help
Randy
__________________
A good plan violently executed now is better than a perfect plan executed next week.
George S. Patton
Randy from Kansas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 09:46.



Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 1,115
364 Members
751 Guests

Most users ever online: 2,244
Nov 11, 2013 at 11:42