Home Forums Classifieds Blogs Today's Posts Search Social Groups



  
SIGN-UP
Notices

Glock Talk
Welcome To The Glock Talk Forums.

 
  
Reply
 
Thread Tools Display Modes
Old 08-29-2010, 21:37   #1
JTB
always learning
 
Join Date: Aug 2003
Location: Santa Clara CA
Posts: 758
Mossberg SPX question

OK I own one and last time I used it it hold and feed all seven from the magazine. When to use it today and if I put more then 3 shells in the magazine, nothing feeds. any ideas folks?
Thanks
__________________
John

The internet is like a 12 step group, take what you need and leave the rest.
JTB is offline   Reply With Quote
Old 08-29-2010, 22:48   #2
Glocker08
Senior Member
 
Glocker08's Avatar
 
Join Date: Sep 2008
Posts: 1,863
Quote:
Originally Posted by JTB View Post
OK I own one and last time I used it it hold and feed all seven from the magazine. When to use it today and if I put more then 3 shells in the magazine, nothing feeds. any ideas folks?
Thanks
I don't own a Mossy SPX, but my first guess would be something is going on with the mag spring. Maybe its getting hung up on something or maybe you need to replace it with a stronger spring. This is just a guess of course.

Also, were you using the same type of ammo each time ? If it was different, maybe thats got something to do with it.

At any rate, let us know when you figure out what it is.

Last edited by Glocker08; 08-29-2010 at 22:50..
Glocker08 is offline   Reply With Quote
Old 08-29-2010, 23:09   #3
JTB
always learning
 
Join Date: Aug 2003
Location: Santa Clara CA
Posts: 758
Thanks, It was the same ammo
__________________
John

The internet is like a 12 step group, take what you need and leave the rest.
JTB is offline   Reply With Quote
Old 08-30-2010, 01:51   #4
mixflip
Senior Member
 
Join Date: Mar 2009
Posts: 6,774
Most folks ignore or forget to properly clean their SPX before breaking it in but I dont think thats the problem. It sounds like the spring or follower is getting hung up somewhere? Possibly the interface inside where the mag extension meets the magazine?

If its brand new. Clean it. lube it properly. Try and use a few boxes of 00 buck and that should break it in fairly well? I did it this way and have been popping off cheap lowbrass WalMart birdshot ever since with zero malfunctions ever since day one.
mixflip is offline   Reply With Quote
Old 08-30-2010, 07:21   #5
F_G
Senior Member
 
F_G's Avatar
 
Join Date: Jan 2010
Location: Crown King, AZ
Posts: 915
I had the same problem occassionally with mine. It was the follower hanging up on the transition from the mag tube to the extension tube. I took a fine file and beveled the edges of the follower (the factory follower has very sharp edges) and with a round file chamfered the tube and extension. I have since had no more issues.
__________________
"You live more in 5 minutes on a motorcycle
than some people do in a lifetime"-B. Munro

F_G is offline   Reply With Quote
Old 08-30-2010, 08:15   #6
skynyrd1911
Senior Member
 
skynyrd1911's Avatar
 
Join Date: Aug 2007
Location: Crowley's Ridge
Posts: 218
Send a message via ICQ to skynyrd1911
I've never had a problem with mine. Cleaned & lubricated first thing out of the box. Ran a couple of boxes of slugs and buckshot through it and then about 50 rounds of cheap birdshot. No issues whatsoever. Last time out 1 box of slugs and 25 rounds of birdshot, no problem. That being said, I've only run about 100 rounds through it total. Excellent shotgun for the money.
__________________
When everything is coming your way, you're in the wrong lane.
skynyrd1911 is offline   Reply With Quote
Old 08-30-2010, 09:57   #7
JTB
always learning
 
Join Date: Aug 2003
Location: Santa Clara CA
Posts: 758
Quote:
Originally Posted by F_G View Post
I had the same problem occassionally with mine. It was the follower hanging up on the transition from the mag tube to the extension tube. I took a fine file and beveled the edges of the follower (the factory follower has very sharp edges) and with a round file chamfered the tube and extension. I have since had no more issues.
Thanks, I have had it a couple of years so maybe it it the follower. I was think of getting a Choato spring and follower
__________________
John

The internet is like a 12 step group, take what you need and leave the rest.
JTB is offline   Reply With Quote
Old 08-30-2010, 10:11   #8
DFin
Senior Member
 
Join Date: Mar 2008
Posts: 2,189
Don't they come with Choate followers? The mag extensions are made by Choate.
DFin is offline   Reply With Quote
Old 08-30-2010, 10:52   #9
JTB
always learning
 
Join Date: Aug 2003
Location: Santa Clara CA
Posts: 758
The follower is just a cheap piece of metal, best I can tell, the Choate are orange.
__________________
John

The internet is like a 12 step group, take what you need and leave the rest.
JTB is offline   Reply With Quote

 
  
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -6. The time now is 03:25.




Homepage
FAQ
Forums
Calendar
Advertise
Gallery
GT Wiki
GT Blogs
Social Groups
Classifieds


Users Currently Online: 514
130 Members
384 Guests

Most users ever online: 2,672
Aug 11, 2014 at 2:31